The Accomodation of Students HDU - 2444(二分匹配判断+最大匹配)

There are a group of students. Some of them may know each other, while others don’t. For example, A and B know each other, B and C know each other. But this may not imply that A and C know each other.

Now you are given all pairs of students who know each other. Your task is to divide the students into two groups so that any two students in the same group don’t know each other.If this goal can be achieved, then arrange them into double rooms. Remember, only paris appearing in the previous given set can live in the same room, which means only known students can live in the same room.

Calculate the maximum number of pairs that can be arranged into these double rooms.
Input
For each data set:
The first line gives two integers, n and m ( 1 < n <= 200 ) , indicating there are n students and m pairs of students who know each other. The next m lines give such pairs.

Proceed to the end of file.

Output
If these students cannot be divided into two groups, print “ N o ”. Otherwise, print the maximum number of pairs that can be arranged in those rooms.
Sample Input
4 4
1 2
1 3
1 4
2 3
6 5
1 2
1 3
1 4
2 5
3 6
Sample Output
No
3
评论:就是一个二分匹配的判断加一个二分匹配的最大匹配。上课随手撸了一发,但是没有c++的编译器,就用java写了,java写图论的题太怪了!!!
但是为什么用数组指针实现的建边比链接表在实际运行还慢20ms额,不是应该跟快么???
代码:

import java.util.Arrays;
import java.util.Scanner;


public class Main 
{
    static int n,m;
    static final int maxx=205;
    static final int maxn=20005;
    static int head[]=new int[maxx];
    static int next[]=new int[maxn];
    static int to[]=new int[maxn];
    static int cnt=0;
    static void addEdge(int x,int y)
    {
        to[++cnt]=y;next[cnt]=head[x];head[x]=cnt;
        to[++cnt]=x;next[cnt]=head[y];head[y]=cnt;
    }
    static int vis[]=new int[maxx];
    static boolean sign;
    static void dfs(int v,int color)
    {
        vis[v]=color;
        for(int i=head[v];i>0;i=next[i])
        {
            int u=to[i];
            if(vis[u]==0)
            {
                dfs(u,3-color);
                if(sign)
                    return;
            }
            else
                if(vis[u]==vis[v])
                {
                    sign=true;
                    return;
                }
        }
    }
    static boolean check()
    {
        Arrays.fill(vis, 0);
        sign=false;
        for(int i=1;i<=n;i++)
        {
            if(vis[i]==0)
            {
                dfs(i,1);
                if(sign)
                    return false;
            }
        }
        return true;
    }
    static int match[]=new int[maxx];
    static boolean M(int v)
    {
        for(int i=head[v];i>0;i=next[i])
        {
            int u=to[i];
            if(vis[u]!=0)
                continue;
            vis[u]=1;
            if(match[u]==0||M(match[u]))
            {
                match[v]=u;
                match[u]=v;
                return true;
            }
        }
        return false;
    }
    static void init()
    {
        Arrays.fill(head, 0);
        cnt=0;
    }
    public static void main(String[] args)
    {
//      System.out.println("ajaj");
        Scanner sc=new Scanner(System.in);
        while(sc.hasNext())
        {
            init();
            n=sc.nextInt();
            m=sc.nextInt();
            for(int i=0;i<m;i++)
                addEdge(sc.nextInt(),sc.nextInt());

            if(!check())
                System.out.println("No");
            else
            {
                Arrays.fill(match, 0);
                int ans=0;
                for(int i=1;i<=n;i++)
                {
                    if(match[i]==0)
                    {
                        Arrays.fill(vis, 0);
                        if(M(i))
                            ans++;
                    }
                }
                System.out.println(ans);
            }
        }
    }
}

猜你喜欢

转载自blog.csdn.net/coldfresh/article/details/80094085
今日推荐