HDU 1083 二分图匹配 模板

                                                     Courses

Time Limit: 20000/10000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12722 Accepted Submission(s): 5943

Problem Description
Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:

. every student in the committee represents a different course (a student can represent a course if he/she visits that course)

. each course has a representative in the committee

Your program should read sets of data from a text file. The first line of the input file contains the number of the data sets. Each data set is presented in the following format:

P N
Count1 Student1 1 Student1 2 … Student1 Count1
Count2 Student2 1 Student2 2 … Student2 Count2

CountP StudentP 1 StudentP 2 … StudentP CountP

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses . from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you’ll find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.

There are no blank lines between consecutive sets of data. Input data are correct.

The result of the program is on the standard output. For each input data set the program prints on a single line “YES” if it is possible to form a committee and “NO” otherwise. There should not be any leading blanks at the start of the line.

An example of program input and output:

Sample Input
2
3 3
3 1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1

Sample Output
YES
NO

题目意思:有p门课,n个学生,对于每门课都有作为该课课代表的候选人若干个,问能不能给每门课找到一个课代表(一个学生只能当一个课代表)。直接用二分图匹配一下就行了。

AC code:

#include<bits/stdc++.h>
using namespace std;
int line[330][330];
int peo[330];
int v[330];
int n,p;
int find_p(int x)
{
    for(int i=1; i<=n; i++) //遍历people
    {
        if(line[x][i] && !v[i])
        {
            v[i]=1;
            if(peo[i]==0 || find_p(peo[i]))   //该人没有归属或者归属了但是归属的课程有另外的选择
            {
                peo[i] = x;
                return 1;
            }
        }
    }
    return 0;
}
/*对于初学二分图的童鞋(大佬跳过)find_p()的作用是当给当前课程匹配时,看是否选中的人
已经被其他课程选中,如果是,那么回到这门选了这个人的课程,看看是否这门课可以腾
出位置去选其他人,最终的到符合的方案就返回。*/
int main ()
{
    int t,num,x;
    cin>>t;
    while(t--)
    {
        memset(line,0,sizeof(line));
        memset(v,0,sizeof(v));
        memset(peo,0,sizeof(peo));
        cin>>p>>n;
        if(p>n) cout<<"NO"<<endl;
        else{
            
            for(int i=1; i<=p; i++)
            {
                cin>>num;
                for(int j=0; j<num; j++)
                {
                    cin>>x;
                    line[i][x]=1;
                }
            }
            int sum=0;
            for(int i=1; i<=p; i++)
            {
                memset(v,0,sizeof(v));
                if(find_p(i)) sum++;
            }
            if(sum==p) cout<<"YES"<<endl;
            else cout<<"NO"<<endl;
        }
    }
    return 0;
}
发布了22 篇原创文章 · 获赞 4 · 访问量 545

猜你喜欢

转载自blog.csdn.net/yp0413170331/article/details/97778427