【POJ - 1836】Alignment(dp,LIS,最长上升子序列类问题)

版权声明:欢迎学习我的博客,希望ACM的发展越来越好~ https://blog.csdn.net/qq_41289920/article/details/89325620

题干:

In the army, a platoon is composed by n soldiers. During the morning inspection, the soldiers are aligned in a straight line in front of the captain. The captain is not satisfied with the way his soldiers are aligned; it is true that the soldiers are aligned in order by their code number: 1 , 2 , 3 , . . . , n , but they are not aligned by their height. The captain asks some soldiers to get out of the line, as the soldiers that remain in the line, without changing their places, but getting closer, to form a new line, where each soldier can see by looking lengthwise the line at least one of the line's extremity (left or right). A soldier see an extremity if there isn't any soldiers with a higher or equal height than his height between him and that extremity. 

Write a program that, knowing the height of each soldier, determines the minimum number of soldiers which have to get out of line. 

Input

On the first line of the input is written the number of the soldiers n. On the second line is written a series of n floating numbers with at most 5 digits precision and separated by a space character. The k-th number from this line represents the height of the soldier who has the code k (1 <= k <= n). 

There are some restrictions: 
• 2 <= n <= 1000 
• the height are floating numbers from the interval [0.5, 2.5] 

Output

The only line of output will contain the number of the soldiers who have to get out of the line.

Sample Input

8
1.86 1.86 1.30621 2 1.4 1 1.97 2.2

Sample Output

4

题目大意:

n个士兵排队,问你最少需要出列几个人,才能使得剩下的每一个士兵要么向左看可以看到无穷远,要么向右看可以看到无穷远。定义无穷远,当且仅当那一个方向的所有人的身高都小于他。

解题报告:

求两边LIS然后n^2枚举分界点就可以了。

AC代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<map>
#include<vector>
#include<set>
#include<string>
#include<cmath>
#include<cstring>
#define F first
#define S second
#define ll long long
#define pb push_back
#define pm make_pair
using namespace std;
typedef pair<int,int> PII;
const int MAX = 2e5 + 5;
double v[MAX];
int a[MAX],b[MAX];
int n;
int main()
{
	cin>>n;
	for(int i = 1; i<=n; i++) scanf("%lf",v+i),a[i] = b[i] = 1;
	for(int i = 1; i<=n; i++) {
		for(int j = 1; j<=i-1; j++) {
			if(v[i] > v[j]) a[i] = max(a[i],a[j] + 1);		
		}
	}
	for(int i = n; i>=1; i--) {
		for(int j = n; j>i; j--) {
			if(v[i] > v[j]) b[i] = max(b[i],b[j] + 1);		
		}
	}
	int ans = 0;
	for(int i = 1; i<=n; i++) {
		for(int j = i+1; j<=n; j++) {
			ans = max(ans,a[i] +b[j]);
		}
	}
	printf("%d\n",n - ans);
	return 0 ;
}

猜你喜欢

转载自blog.csdn.net/qq_41289920/article/details/89325620