poj 3616(DP之最长上升子序列(区间区间))

Milking Time
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 13113   Accepted: 5541

Description

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri < ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

Input

* Line 1: Three space-separated integers: NM, and R
* Lines 2..M+1: Line i+1 describes FJ's ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output

* Line 1: The maximum number of gallons of milk that Bessie can product in the N hours

Sample Input

12 4 2
1 2 8
10 12 19
3 6 24
7 10 31

Sample Output

43

一开始我以为这是一道01背包,但是被WA了,虽然样例过了,但是这道题是区间问题,也就是不能用01背包的思想来做

#include<cstdio>
#include<cstring>
#include<iostream>
#include<cmath>
#include<algorithm>
using namespace std;
#define MAXN 40005
#define mem(a,b) memset(a,b,sizeof(a));
int dp[2000];
struct node
{
    int star;
    int ending;
    int efficiency;
}a[1002];
bool cmp(node a,node b)
{
    if(a.star==b.star)
        return a.ending<b.ending;
    else
        return a.star<b.star;
}
int main()
{
    int n,m,r;
    cin>>n>>m>>r;
    for(int i=0;i<m;i++)
    {
        int k;
        cin>>a[i].star>>k>>a[i].efficiency;
        a[i].ending=k+r;
    }
    sort(a,a+m,cmp);
//    for(int i=0;i<m;i++)
//        cout<<a[i].star<<"  "<<a[i].ending<<" ";
int ans=0;
    for(int i=0;i<m;i++)
    {
        dp[i]=a[i].efficiency;
            for(int j=0;j<i;j++)
            {
                if(a[i].star>=a[j].ending)
                dp[i]=max(dp[i],dp[j]+a[i].efficiency);
            }
    }
    int mm=*max_element(dp,dp+m);
    cout<<mm<<endl;
    return 0;
}
如果用01背包的话dp[j]表示时间为j时最大的获取值
#include<cstdio>
#include<cstring>
#include<iostream>
#include<cmath>
#include<algorithm>
using namespace std;
#define MAXN 40005
#define mem(a,b) memset(a,b,sizeof(a));
int dp[2000000];
struct node
{
    int star;
    int ending;
    int efficiency;
}a[1002];
bool cmp(node a,node b)
{
    if(a.star==b.star)
        return a.ending<b.ending;
    else
        return a.star<b.star;
}
int main()
{
    int n,m,r;
    cin>>n>>m>>r;
    for(int i=0;i<m;i++)
    {
        int k;
        cin>>a[i].star>>k>>a[i].efficiency;
        a[i].ending=k+r;
    }
    sort(a,a+m,cmp);
    dp[a[0].ending]=a[0].efficiency;
    for(int i=0;i<m;i++)
    for(int j=n+r;j>=a[i+1].ending;j--)
    {

            dp[j]=max(dp[a[i].ending],dp[j-a[i+1].ending+a[i+1].star]+a[i+1].efficiency);//通过debug就发现,样例的第二次就不符合要求
    }                                                                                    //这里值排完序的样例
    cout<<dp[n+r]<<endl;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/c___c18/article/details/80869533
今日推荐