HDOJ2604 Queuing #递推 矩阵快速幂#

版权声明:while (!success) try(); https://blog.csdn.net/qq_35850147/article/details/89248192

Queuing

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8100    Accepted Submission(s): 3557

Problem Description

Queues and Priority Queues are data structures which are known to most computer scientists. The Queue occurs often in our daily life. There are many people lined up at the lunch time. 


  Now we define that ‘f’ is short for female and ‘m’ is short for male. If the queue’s length is L, then there are 2L numbers of queues. For example, if L = 2, then they are ff, mm, fm, mf . If there exists a subqueue as fmf or fff, we call it O-queue else it is a E-queue.
Your task is to calculate the number of E-queues mod M with length L by writing a program.

Input

Input a length L (0 <= L <= 10 6) and M.

Output

Output K mod M(1 <= M <= 30) where K is the number of E-queues with length L.

Sample Input

3 8 4 7 4 8

Sample Output

6 2 1

Author

WhereIsHeroFrom

Source

HDU 1st “Vegetable-Birds Cup” Programming Open Contest

Recommend

lcy   |   We have carefully selected several similar problems for you:  1588 1757 2606 2276 2603

#include <iostream>

using namespace std;

int n, m;
int v[5] = {1, 2, 4, 6, 9};
struct matrix
{
    int mat[4][4];
    void init()
    {
        memset(mat, 0, sizeof(mat));
        for (int i = 0; i < 4; i++)
            mat[i][i] = 1;
    }
};

matrix mul(const matrix &a, const matrix &b)
{
    matrix ans;
    for (int i = 0; i < 4; i++)
    {
        for (int j = 0; j < 4; j++)
        {
            ans.mat[i][j] = 0;
            for (int k = 0; k < 4; k++)
                ans.mat[i][j] = (ans.mat[i][j] + a.mat[i][k] * b.mat[k][j]) % m;
        }
    }
    return ans;
}

matrix quick_pow(matrix a, int n)
{
    matrix ans;
    ans.init();
    while (n)
    {
        if (n & 1)
            ans = mul(ans, a);
        a = mul(a, a);
        n >>= 1;
    }
//    TLE
//    while (n--)
//        ans = mul(ans, a);
    return ans;
}

int main()
{
    matrix base;
    memset(base.mat, 0, sizeof(base.mat));
    base.mat[0][0] = base.mat[0][2] = base.mat[0][3] = base.mat[1][0] = base.mat[2][1] = base.mat[3][2] = 1;
    while (~scanf("%d%d", &n, &m))
    {
        if (n <= 4)
            printf("%d\n", v[n] % m);
        else
        {
            matrix pow = quick_pow(base, n - 4);
            int ans = 0;
            for (int i = 0; i < 4; i++)
                ans = (ans + pow.mat[0][i] * v[4 - i]) % m;
            printf("%d\n", ans);
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_35850147/article/details/89248192