Binary String Matching(字符串哈希)

Binary String Matching


描述
Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while the pattern string A is ‘11’, you should output 3, because the pattern A appeared at the posit


输入
The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10, and the second line gives the string B, length (B) <= 1000. And it is guaranteed that B is always longer than A.


输出
For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A.


样例输入
3
11
1001110110
101
110010010010001
1010
110100010101011


样例输出
3
0
3


字符串hash

#include<bits/stdc++.h>
typedef unsigned long long ull; 
const int m=233;
const int maxn=1e6+7;
using namespace std;
char str1[maxn],str2[maxn];
int main(){
    int n;
    ull a,b,t;
    long long ans;
    scanf("%d",&n);
    while(n--){
        ans=0;
        a=0;
        b=0;
        t=1;
        scanf("%s %s",&str1,&str2);
        int len1=strlen(str1);
        int len2=strlen(str2);
        for(int i=0;i<len1;i++) t=t*m;
        for(int i=0;i<len1;i++) a=a*m+str1[i];//子串 
        for(int i=0;i<len1;i++) b=b*m+str2[i];//母串 
        for(int i=0;i+len1<=len2;i++){
            if(b==a)
                ans++;
            b=b*m-str2[i]*t+str2[i+len1];
        }   
        printf("%lld\n",ans);
    }
    return 0;
}

暂时没看懂

#include<iostream>
#include<string>
using namespace std;
int main()
{
    string s1,s2;
    int n;
    cin>>n;
    while(n--)
    {
        cin>>s1>>s2;
        unsigned int m=s2.find(s1,0);
        int num=0;
        while(m!=string::npos)
        {
            num++;
            m=s2.find(s1,m+1);
        }
        cout<<num<<endl;
    }
}        

猜你喜欢

转载自blog.csdn.net/shf1730797676/article/details/82526238
今日推荐