南阳理工OJ-5 Binary String Matching(子字符串问题)

Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while the pattern string A is ‘11’, you should output 3, because the pattern A appeared at the posit
输入
The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10, and the second line gives the string B, length (B) <= 1000. And it is guaranteed that B is always longer than A.
输出
For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A.
样例输入
3
11
1001110110
101
110010010010001
1010
110100010101011 
样例输出
3
0
3 

就是简单的找子字符串:

#include<iostream>
#include<string>
using namespace std;
int main(){
	int t,m,n,ans;
	cin>>t;
	while(t--){
		string a,b;
		ans=0;
		cin>>b>>a;
		m=a.length();
        n=b.length();
        for(int i=0;i<=m-n;i++){
        	if(b==a.substr(i,n)){
        		ans++;
			}
		}
		cout<<ans<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40922859/article/details/80321750