Binary String Matching  STL string

描述

Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while the pattern string A is ‘11’, you should output 3, because the pattern A appeared at the posit

输入

The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10, and the second line gives the string B, length (B) <= 1000. And it is guaranteed that B is always longer than A.

输出

For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A.

样例输入

3
11
1001110110
101
110010010010001
1010
110100010101011 

样例输出

3
0
3 

#include<iostream>
#include<string>
#include<stdio.h>
using namespace std;
int main()
{
    int N;
    scanf("%d",&N);
    while(N--)
    {
        string a, b;
        cin>>a>>b;
        int count = 0; 
        int position = b.find(a,0);//find 函数 返回jk 在s 中的下标位置 
        while(position!=string::npos)
        {
            count++;
            position = b.find(a,position+1);
        }
        printf("%d\n",count);
    }
    return 0;
}
/*先说说string::npos参数: 
npos 是一个常数,用来表示不存在的位置,类型一般是std::container_type::size_type 许多容器都提供这个东西。取值由实现决定,一般是-1,这样做,就不会存在移植的问题了。 
再来说说find函数: 
find函数的返回值是整数,假如字符串存在包含关系,其返回值必定不等于npos,但如果字符串不存在包含关系,那么返回值就一定是npos。*/

猜你喜欢

转载自blog.csdn.net/qq_40835329/article/details/81587699