南阳 oj Binary String Matching 题目5

1、题目信息

Binary String Matching

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 3
描述
Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while the pattern string A is ‘11’, you should output 3, because the pattern A appeared at the posit
输入
The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10, and the second line gives the string B, length (B) <= 1000. And it is guaranteed that B is always longer than A.
输出
For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A.
样例输入
3
11
1001110110
101
110010010010001
1010
110100010101011 
样例输出
3
0
3 

2、题目大致意思

    第一次输入一个整数n,代表此时组数,接着输出n组测试用例,每组包含两行a、b字符串,a的长度<=10,b的长度<=1000

    输出b中包含多少个a。

3、思路

    1)使用c++ 中string类来处理

    2)对于遍历字符串b,每次取出长度为a的字串,进行判断

4、代码

#include <iostream>
#include <string>
using namespace std;
int main()
{
    string a,b;
    int n,m;
    cin>>n;
    while(n--){
        m=0;
        cin>>a;
        cin>>b;
        for(int i=0;i<b.length();i++){
            if(b.substr(i,a.length())==a) m++;
        }
        cout<<m<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sicauliuy/article/details/80201162