1108 Finding Average (20 分)

版权声明:SupremeBeast3_ https://blog.csdn.net/weixin_43359312/article/details/89085482

1108 Finding Average (20 分)

The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A legal input is a real number in [−1000,1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then N numbers are given in the next line, separated by one space.

Output Specification:
For each illegal input number, print in a line ERROR: X is not a legal number where X is the input. Then finally print in a line the result: The average of K numbers is Y where K is the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output Undefined instead of Y. In case K is only 1, output The average of 1 number is Y instead.

Sample Input 1:
7
5 -3.2 aaa 9999 2.3.4 7.123 2.35
Sample Output 1:
ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38
Sample Input 2:
2
aaa -9999
Sample Output 2:
ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

AC代码

#include <iostream>
#include <string>
#include <cstdio>
using namespace std;
int main() {
	int N;
	cin >> N;
	double Sum = 0.0, Average = 0.0;
	int Hcnt = 0;
	string Num;
	while (N--) {
		cin >> Num;
		int Sign = 1;
		if (Num[0] == '-') Sign = -1;	//负数
		int HFlag = 1, TheNum = 0, Power = 1, Pcnt = 0, Wcnt = 0;
		for (int i = 0; i < Num.size(); i++) {
			HFlag = 1;
			if (Num[i] > '9' || Num[i] < '0') {		//非数字字符的情况分析
				if (Num[i] == '.') {	//遇到小数点的情况分析
					if (!i) { HFlag = 0; break; }	//第一个即为'.'非法
					else if (Pcnt == 1) { HFlag = 0; break; }	//超过一个'.'非法
					else {
						if (Num[i - 1] != '-') Pcnt++;	//记录已有小数点
						else { HFlag = 0; break; }	// '-.'非法
					}
				}
				else if (Num[i] == '-') {	//遇到负号的情况分析
					if (i) { HFlag = 0; break; }	//负号在非首位出现非法
					else if (!Num[1]) { HFlag = 0; break; }	//数字仅有一个负号非法
				}
				else { HFlag = 0; break; }	//其他非数字字符均非法
			}
			else {		//数字字符的情况分析
				if (Pcnt == 1) { Wcnt++; Power *= 10; }		//如果此数为小数
				TheNum = TheNum * 10 + (Num[i] - '0');
				if (TheNum*1.0/Power > 1000) { HFlag = 0; break; }	//如果超过1000非法
			}
		}
		if (HFlag) {	//初步筛选合法数的情况分析
			if (Wcnt >= 3) cout << "ERROR: " << Num << " is not a legal number" << endl;	//小数部分超过三位非法
			else { Hcnt++; Sum = Sum + (TheNum*1.0 / Power * Sign); }	//合法数
		}
		else cout << "ERROR: " << Num << " is not a legal number" << endl;	//初步筛选时已非法
	}
	if (Hcnt) {		//有合法数的情况
		Average = Sum / Hcnt;
		if (Hcnt == 1) cout << "The average of " << Hcnt << " number is ";	//仅有一个合法数时
		else cout << "The average of " << Hcnt << " numbers is ";	//有多个合法数时
		printf("%.2lf\n", Average);
	}
	else cout << "The average of 0 numbers is Undefined" << endl;	//无合法数时
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43359312/article/details/89085482
今日推荐