1108. Finding Average (20)

版权声明:文章都是原创,转载请注明~~~~ https://blog.csdn.net/SourDumplings/article/details/86652748

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A "legal" input is a real number in [-1000, 1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=100). Then N numbers are given in the next line, separated by one space.

Output Specification:

For each illegal input number, print in a line "ERROR: X is not a legal number" where X is the input. Then finally print in a line the result: "The average of K numbers is Y" where K is the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output "Undefined" instead of Y. In case K is only 1, output "The average of 1 number is Y" instead.

Sample Input 1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

Sample Output 1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

Sample Input 2:

2
aaa -9999

Sample Output 2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

C++:

/*
 @Date    : 2018-02-26 11:26:29
 @Author  : 酸饺子 ([email protected])
 @Link    : https://github.com/SourDumplings
 @Version : $Id$
*/

/*
https://www.patest.cn/contests/pat-a-practise/1108
思路来自:
https://www.liuchuo.net/archives/1924
sscanf() – 从一个字符串中读进与指定格式相符的数据
sprintf() – 字符串格式化命令,主要功能是把格式化的数据写入某个字符串中。
 */

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

int main(int argc, char const *argv[])
{
    int N;
    scanf("%d", &N);
    int count = 0;
    char temp[50], numString[50];
    double num = 1001; // 一定要初始化,否则对于第一个不合法值其numString会很奇怪
    bool legal = true;
    double sum = 0;
    for (int i = 0; i != N; ++i)
    {
        legal = true;
        scanf("%s", temp);
        sscanf(temp, "%lf", &num);
        sprintf(numString, "%.2f", num);
        for (int j = 0; temp[j] != '\0'; ++j)
            if (temp[j] != numString[j])
            {
                legal = false;
                break;
            }
        if (num < -1000 || 1000 < num || !legal)
            printf("ERROR: %s is not a legal number\n", temp);
        else
        {
            ++count;
            sum += num;
        }

    }
    if (count == 0)
        printf("The average of 0 numbers is Undefined\n");
    else if (count == 1)
        printf("The average of 1 number is %.2f\n", sum);
    else
        printf("The average of %d numbers is %.2f\n",
            count, sum / (static_cast<double>(count)));
    return 0;
}

猜你喜欢

转载自blog.csdn.net/SourDumplings/article/details/86652748
今日推荐