PAT-1108 Finding Average

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/eric4784510/article/details/82227211

1108 Finding Average(20 分)

The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A legalinput is a real number in [−1000,1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then N numbers are given in the next line, separated by one space.

Output Specification:

For each illegal input number, print in a line ERROR: X is not a legal number where X is the input. Then finally print in a line the result: The average of K numbers is Y where K is the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output Undefined instead of Y. In case K is only 1, output The average of 1 number is Y instead.

Sample Input 1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

Sample Output 1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

Sample Input 2:

2
aaa -9999

Sample Output 2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

    字符串转double有多种方法:

         double d = (double)strtod(s.c_str(),NULL);

         sscanf(s.c_str(),"%lf",&d);

         stringstream st(s);  st >> d;

#include<stdio.h>
#include<vector>
#include<string>
#include<sstream>
#include<algorithm>
using namespace std;

vector<double> leg;
double str2double(string s){
	double d;
	stringstream st(s);
	st>>d;
	return d;
}
int main(){
	int n;
	scanf("%d",&n);
	char c[1000];
	for(int i=0;i<n;i++){
		scanf("%s",c);
		
		string s(c);
		int dot=-1;bool ok=true;
		for(int i=0;i<s.size();i++){
			if((s[i]>'9'||s[i]<'0')){
				if(s[i]=='.'){
					if(dot>0||i==0){
						ok=false;
						break;
					}
					dot=i;
				}else if(i==0&&s[i]=='-'){
					continue;
				}else{
					ok=false;
					break;
				}
			}
		}
		if(dot>0&&s.size()-1-dot>2)
			ok=false;
		double d=str2double(s);
		if(d>1000||d<-1000)
			ok=false;

		if(ok){
			leg.push_back(d);
		}else{
			printf("ERROR: %s is not a legal number\n",s.c_str());
		}
	}
	double sum=0.0;
	for(int i=0;i<leg.size();i++){
		sum+=leg[i];
	}

	if(leg.size()==0)
		printf("The average of 0 numbers is Undefined");
	else if(leg.size()>1)
		printf("The average of %d numbers is %.2f",leg.size(),sum/leg.size());
	else 
		printf("The average of 1 number is %.2f",leg.size(),sum);

	return 0;
}

猜你喜欢

转载自blog.csdn.net/eric4784510/article/details/82227211
今日推荐