PAT 甲级 1108 Finding Average

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/a845717607/article/details/87885750

1108 Finding Average (20 point(s))

The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A legal input is a real number in [−1000,1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then N numbers are given in the next line, separated by one space.

Output Specification:

For each illegal input number, print in a line ERROR: X is not a legal number where X is the input. Then finally print in a line the result: The average of K numbers is Y where K is the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output Undefined instead of Y. In case K is only 1, output The average of 1 number is Y instead.

Sample Input 1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

Sample Output 1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

Sample Input 2:

2
aaa -9999

Sample Output 2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

经验总结:

emmmmm  简单的划水题,只要不遗漏题目要求就能AC啦~

AC代码

#include <cstdio>
#include <cstring>
#include <cctype>
const int maxn=1010;
char str[maxn];
int n;
bool judge(char s[],double &num)
{
	int i=0,dnum=0,f=0;
	if(s[i]=='-')
		++i;
	for(;s[i]!='\0';++i)
	{
		if(s[i]=='.'&&dnum!=0)
			return false;
		if(!isdigit(s[i])&&s[i]!='.')
			return false;
		if(f!=0)
			++f;
		if(s[i]=='.'&&dnum==0)
		{
			++dnum;
			f=1;
		}
	}
	if(f>3)
		return false;
	sscanf(s,"%lf",&num);
	if(num<=1000&&num>=-1000)
		return true;
	else
		return false;
}

int main()
{
	scanf("%d",&n);
	double num,ans=0;
	int no=0;
	for(int i=0;i<n;++i)
	{
		scanf("%s",str);
		if(judge(str,num))
		{
			ans+=num;
			++no;
		}
		else
			printf("ERROR: %s is not a legal number\n",str);
	}
	if(no==0)
		printf("The average of 0 numbers is Undefined\n");
	else if(no==1)
		printf("The average of 1 number is %.2f\n",ans/no);
	else
		printf("The average of %d numbers is %.2f\n",no,ans/no);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/a845717607/article/details/87885750
今日推荐