1108 Finding Average(20 分)(cj)

1108 Finding Average(20 分)

The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A legal input is a real number in [−1000,1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then N numbers are given in the next line, separated by one space.

Output Specification:

For each illegal input number, print in a line ERROR: X is not a legal number where X is the input. Then finally print in a line the result: The average of K numbers is Y where K is the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output Undefinedinstead of Y. In case K is only 1, output The average of 1 number is Y instead.

Sample Input 1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

Sample Output 1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

Sample Input 2:

2
aaa -9999

Sample Output 2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

我的天 20分的暴力题吓得我直打哆嗦。。。。 

code

#pragma warning(disable:4996)
#include <iostream>
#include <string>
#include <math.h>
#include <stdio.h>
using namespace std;
bool islegal(string s);
double tran(string s);
int main() {
	int n;
	cin >> n;
	string s;
	double res = 0.0;
	int num = 0;
	for (int i = 0;i<n; ++i) {
		cin >> s;
		if (islegal(s)) {
			double x = tran(s);
			if (x >= -1000 && x <= 1000) {
				num++;
				res += tran(s);
			}
			else {
				cout << "ERROR: " << s << " is not a legal number" << endl;
			}
		}
		else {
			cout << "ERROR: "<<s<<" is not a legal number" << endl;
		}
	}
	if (num == 0) {
		printf("The average of 0 numbers is Undefined");
	}
	else if (num == 1) {
		printf("The average of 1 number is %.2f", res);
	}
	else {
		printf("The average of %d numbers is %.2f", num , res/num);
	}
	system("pause");
	return 0;
}
double tran(string s) {
	double sum = 0;
	bool f = 0;
	int pos = s.size()-1;
	for (int i = 0; i < s.size(); ++i) {
		if (s[i] == '-') {
			f = 1;
			continue;
		}
		if (s[i] == '.') {
			pos = i;
			continue;
		}
		sum *= 10;
		sum += (s[i] - '0');
	}
	if (f) sum = -sum;
	sum /= pow(10, s.size()-1 - pos);
	return sum;
}
bool islegal(string s) {
	int pos = s.size()-1;
	int num = 0;
	for (int i = 0; i < s.size(); ++i) {
		if (s[i] == '.' || s[i] >= '0'&&s[i] <= '9' || s[i] == '-'&&i == 0) {
			if (s[i] == '.') {
				pos = i;
				num++;
			}
		}
		else return 0;
	}
	if (num > 1) return 0;
	if (s.size() - 1 - pos > 2) return 0;
	return 1;
}

猜你喜欢

转载自blog.csdn.net/Cute_jinx/article/details/82501573
今日推荐