PAT甲级-1108 Finding Average(20 分)

1108 Finding Average(20 分)

The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A legal input is a real number in [−1000,1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then N numbers are given in the next line, separated by one space.

Output Specification:

For each illegal input number, print in a line ERROR: X is not a legal number where X is the input. Then finally print in a line the result: The average of K numbers is Y where K is the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output Undefined instead of Y. In case K is only 1, output The average of 1 number is Y instead.

Sample Input 1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

Sample Output 1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

Sample Input 2:

2
aaa -9999

Sample Output 2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

解题思路:这题我自己不想写的那么复杂,就百度看一下别人的代码,别人的代码就是不一样,自己太菜了,居然没有想到sscanf,sprintf,这2个真的好用,要好好掌握。

#include<bits/stdc++.h>
using namespace std;
int main(void)
{
	int n;
	scanf("%d",&n);
	char a[50],b[50];
	int count=0;
	double temp=0.0,sum=0.0;
	while(n--)
	{
		scanf("%s",a);
		sscanf(a,"%lf",&temp);
		sprintf(b,"%.2lf",temp);
		int flag=1;
		for(int i=0;i<strlen(a);i++)
		{
			if(a[i]!=b[i])
			{
				flag=0;
				break;
			 } 
		}
		if(!flag||temp<-1000||temp>1000)
		{
			printf("ERROR: %s is not a legal number\n",a);
			continue;
		}
		else{
			count++;
		sum+=temp;
		}	
	}
	if(count==1) printf("The average of 1 numbers is %.2lf",sum);
	else if(count>1) printf("The average of %d numbers is %.2lf",count,sum/count);
	else printf("The average of 0 numbers is Undefined");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Imagirl1/article/details/82053254
今日推荐