PAT A1078

  • 题目:
    The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.
Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (≤10​4​​) and N (≤MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.
Output Specification:

For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print “-” instead.
Sample Input:

4 4
10 6 4 15

Sample Output:

0 1 4 -

  • 解题思路
    需要解决的问题:
    1.找出大于等于表长的最小素数
bool is_prime(int n) {               //判断整数是否为素数
	if (n <= 1)
		return false;
	int sq = sqrt(1.0 * n);
	for (int i = 2; i <= sq; i++) {
		if (n % i == 0)
			return false;
	}
	return true;
}
int sma_prime(int n)    //返回最小的素数
{
	int val = 0;
	for (int i = n;i < Max; i++) {
		if (is_prime(i)) {
			val = i;
			break;
		}
	}
	return val;
}

2.如和处理hash表中的冲突
利用正向平方探测法:
M = (a+step*step)%Tsize;
a为最先应插入的位置
step取值为1~Tsize-1;

cin >> k;
		int M = k % size1;
		if (tag[M]) {
			int j;
			for (j = 1; j < size1; j++) {
				M = (k + j*j) % size1;
				if (tag[M] == false) {
					tag[M] = true;
					st.push_back(to_string(M));
					break;
				}
			}

3.如何控制输出
利用vectorst;
若输出为整数,通过to_string 函数将其转化为string类型

此题代码:

#include <iostream>
#include <string>
#include <vector>
#include <cmath>
using namespace std;
const int Max = 11111;
bool is_prime(int n) {               //判断整数是否为素数
	if (n <= 1)
		return false;
	int sq = sqrt(1.0 * n);
	for (int i = 2; i <= sq; i++) {
		if (n % i == 0)
			return false;
	}
	return true;
}
int sma_prime(int n)    //返回最小的素数
{
	int val = 0;
	for (int i = n;i < Max; i++) {
		if (is_prime(i)) {
			val = i;
			break;
		}
	}
	return val;
}
int main()
{
	int Tsize, n,k;
	cin >> Tsize >> n;
	int size1 = sma_prime(Tsize);
	bool tag[Max] = { 0 };
	vector<string> st;
	for (int i = 0; i < n; i++) {
		cin >> k;
		int M = k % size1;
		if (tag[M]) {
			int j;
			for (j = 1; j < size1; j++) {
				M = (k + j*j) % size1;
				if (tag[M] == false) {
					tag[M] = true;
					st.push_back(to_string(M));
					break;
				}
			}
			if (j >= size1)
				st.push_back("-");
		} else {
			tag[M] = true;
			st.push_back(to_string(M));
		}
	}
	for (int i = 0; i < st.size() - 1; i++)
		cout << st[i] << " ";
	cout << st[st.size() - 1];
	return 0;
}

猜你喜欢

转载自blog.csdn.net/xiao1guaishou/article/details/88681673
今日推荐