【PAT】A1078. Hashing (25)

Description:
The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be “H(key) = key % TSize” where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (<=104) and N (<=MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print “-” instead.

Sample Input:
4 4
10 6 4 15


Sample Output:
0 1 4 –

题目分析:

  • Quadratic probing     二次方探查法(哈希表解决冲突)

今天PTA的人怎么这么多0.0

//NKW 甲级真题1013
#pragma warning(disable:4996)
#include <stdio.h>
#include <stdlib.h>
const int maxn = 10010;
bool hashtable[maxn];
bool isprime(int a){
	if (a <= 1)	return false;
	for (int i = 2; i * i <= a; i++)
		if (a%i == 0) 
			return false;
	return true;
}
int main(){
	int maxt, n, num, i, j;
	scanf("%d %d", &maxt, &n);
	while (!isprime(maxt))	maxt++;
	for (i = 0; i < n; i++){
		if (i)	printf(" ");
		scanf("%d", &num);
		if (!hashtable[num%maxt]){
			hashtable[num%maxt] = true;
			printf("%d", num%maxt);
		}
		else{		//二次方探查法解决冲突
			for (j = 1; j < maxt; j++){
				if (!hashtable[(num + j*j) % maxt]){
					hashtable[(num + j*j) % maxt] = true;
					printf("%d", (num + j*j) % maxt);
					break;
				}
			}
			if (j>=maxt)
				printf("-");
		}
	}
	printf("\n");
	system("pause");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/ztmajor/article/details/81122337