PAT A 1078 Hashing

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be “H(key) = key % TSize” where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (<=10^4^) and N (<=MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print “-” instead.

Sample Input:

4 4
10 6 4 15

Sample Output:

0 1 4 -

没什么难度。。素数判断加Hashtable,唯一需要注意的是,平方探测法,如果在 j < msize 没有找到位置的话,后面肯定找不到。

#include<cstdio>
#include<cmath>

const int maxn = 10010;
bool Hashtable[maxn] = { false };

bool isPrime(int a) {
    if (a <= 1) return false;
    int sqr = (int)sqrt(a);
    for (int i = 2; i <= sqr; i++) {
        if (a % i == 0) return false;
    }
    return true;
}

int main() {
    int msize, n;
    int num[maxn];
    scanf("%d %d", &msize, &n);
    for (int i = 0; i < n; i++) {
        scanf("%d", &num[i]);
    }
    if (isPrime(msize) == false) {
        while (isPrime(msize) == false) msize++;
    }

    for (int i = 0; i < n; i++) {
        int index = num[i] % msize;
        if (Hashtable[index] == false) {
            printf("%d", index);
            Hashtable[index] = true;
        }
        else {
            for (int j = 1;j<msize; j++) {//j的范围,小于msize
                index = (num[i] + j * j) % msize;
                if (Hashtable[index] == false) {
                    printf("%d", index);
                    Hashtable[index] = true;
                    break;
                }
                if (j == msize - 1) {
                    printf("-");
                    break;
                }
            }

        }
        if (i != n - 1) printf(" ");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/joah_ge/article/details/81066826