PAT:A1078 Hashing (25 分)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/Ecloss/article/details/82664669

PAT:A1078 Hashing (25 分)

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (≤10​4​​) and N (≤MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print "-" instead.

Sample Input:

4 4
10 6 4 15

Sample Output:

0 1 4 -

代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;

const int maxn = 10010;
bool isPrime(int n) {
	if(n <= 1) return false;
	for(int i = 2; i * i <= n; i++) {
		if(n % i == 0) return false;
	}
	return true;
}

bool isFlag1[maxn] = {0};
int main() {
	int MSize, N, p, x, M;
	scanf("%d %d", &MSize, &N);
	while(isPrime(MSize) == false) {
		MSize++;
	}
	for(int i = 0; i < N; i++) {
		scanf("%d", &x);
		p = x % MSize;
		if(isFlag1[p] == false) {
			isFlag1[p] = true;
			if(i == 0) printf("%d", p);
			else printf(" %d", p);
		} else {
			int step;
			for(step = 1; step < MSize; step++) {
				M = (x + step * step) % MSize;
				if(isFlag1[M] == false) {
					isFlag1[M] = true;
					if(i == 0) printf("%d", M);
					else printf(" %d", M);
					break;
				} 
			}
			if(step >= MSize) {
				if(i != 0) printf(" ");
				printf("-");
			}
		}
	}
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/Ecloss/article/details/82664669