hdu4405_Aeroplane chess

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/sumword_/article/details/53164008

Aeroplane chess

Problem Description
Hzz loves aeroplane chess very much. The chess map contains N+1 grids labeled from 0 to N. Hzz starts at grid 0. For each step he throws a dice(a dice have six faces with equal probability to face up and the numbers on the faces are 1,2,3,4,5,6). When Hzz is at grid i and the dice number is x, he will moves to grid i+x. Hzz finishes the game when i+x is equal to or greater than N.

There are also M flight lines on the chess map. The i-th flight line can help Hzz fly from grid Xi to Yi (0<Xi<Yi<=N) without throwing the dice. If there is another flight line from Yi, Hzz can take the flight line continuously. It is granted that there is no two or more flight lines start from the same grid.

Please help Hzz calculate the expected dice throwing times to finish the game.
 

Input
There are multiple test cases. 
Each test case contains several lines.
The first line contains two integers N(1≤N≤100000) and M(0≤M≤1000).
Then M lines follow, each line contains two integers Xi,Yi(1≤Xi<Yi≤N).  
The input end with N=0, M=0. 
 

Output
For each test case in the input, you should output a line indicating the expected dice throwing times. Output should be rounded to 4 digits after decimal point.
 

Sample Input
 
  
2 0 8 3 2 4 4 5 7 8 0 0
 

Sample Output
 
  
1.1667 2.3441
 
题意:有n个格子0~n-1,每次掷筛子得到k,向前走k步,当走到>=n时,游戏结束。同时有m条航线,可以直接由a飞到b,问结束游戏时,掷筛子次数的期望是多少?
思路:由后向前推期望。
#include<bits/stdc++.h>
using namespace std;
double dp[100500];
int fly[100500];
int main(){
    int n,m;
    int temp,temp2;
    while(scanf("%d%d",&n,&m) && n+m){

        for(int i = 1; i <= n+6; i++){
            fly[i] = -1;
            dp[i] = 0;
        }
        for(int i = 1; i <= m; i++){
            scanf("%d%d",&temp,&temp2);
            fly[temp+1] = temp2+1;
        }

        for(int i = n; i >= 1; i--){
            if(fly[i] != -1){
                dp[i] = dp[fly[i]];
            }
            else{
                for(int j = 1; j <= 6; j++){
                    dp[i] += dp[i+j]/6;
                }
                dp[i]++;
            }
        }
        printf("%.4lf\n",dp[1]);

    }
}


猜你喜欢

转载自blog.csdn.net/sumword_/article/details/53164008