概率dp——B - Aeroplane chess HDU - 4405

博客目录

一、原题

题目传送门:https://vjudge.net/contest/208936#problem/B

(可能有密码,请自行vjudge搜 HDU - 4405)

Ivan is fond of collecting. Unlike other people who collect post stamps, coins or other material stuff, he collects software bugs. When Ivan gets a new program, he classifies all possible bugs into n categories. Each day he discovers exactly one bug in the program and adds information about it and its category into a spreadsheet. When he finds bugs in all bug categories, he calls the program disgusting, publishes this spreadsheet on his home page, and forgets completely about the program. 
Two companies, Macrosoft and Microhard are in tight competition. Microhard wants to decrease sales of one Macrosoft program. They hire Ivan to prove that the program in question is disgusting. However, Ivan has a complicated problem. This new program has s subcomponents, and finding bugs of all types in each subcomponent would take too long before the target could be reached. So Ivan and Microhard agreed to use a simpler criteria --- Ivan should find at least one bug in each subsystem and at least one bug of each category. 
Macrosoft knows about these plans and it wants to estimate the time that is required for Ivan to call its program disgusting. It's important because the company releases a new version soon, so it can correct its plans and release it quicker. Nobody would be interested in Ivan's opinion about the reliability of the obsolete version. 
A bug found in the program can be of any category with equal probability. Similarly, the bug can be found in any given subsystem with equal probability. Any particular bug cannot belong to two different categories or happen simultaneously in two different subsystems. The number of bugs in the program is almost infinite, so the probability of finding a new bug of some category in some subsystem does not reduce after finding any number of bugs of that category in that subsystem. 
Find an average time (in days of Ivan's work) required to name the program disgusting.
Input
Input file contains two integer numbers, n and s (0 < n, s <= 1 000).
Output
Output the expectation of the Ivan's working days needed to call the program disgusting, accurate to 4 digits after the decimal point.
Sample Input
1 2
Sample Output
3.0000


二、题目大意:

题意:一个程序有s个子系统,n种bug,一天发现一个bug,这个bug出现在每个子系统的概率相同且不会同时属于两个子系统,同理,是每种bug的概率相同。求发现每个子系统至少一个bug,每种bug至少一个的天数期望。

(题意copy自互联网)

三、分析:

期望倒着算,概率正着算

  • 定义状态:   dp[i]表示 从i走到大于等于n的格子的期望
  • 则状态转移:  dp[i]= dp[i+k]/6+1;
  • ps:               概率dp事实上只有动态,没有规划。

四、AC代码:

#include<bits/stdc++.h>
using namespace std;
/*
  qq1176611589
*/
typedef struct node
{
	int x,y;
}node;
bool operator<(node a,node b)
{
	return a.x<b.x;
}
vector<node>book;
double dp[100000+10];//至少多余出6个空间 
int main()
{
	int n,i,j,k;
	node t;
	int m;
	while(cin>>n>>m,n||m)
	{
		book.clear();
		for(i=0;i<m;i++)
		{
			scanf("%d %d",&t.x,&t.y);
			book.push_back(t);
		}
		sort(book.begin(),book.end());
		j=n-1;
		dp[n]=0;	//
		for(i=m-1;i>=0;i--)
		{
			for(;j>book[i].x;j--)
			{
				for(k=1;k<=6;k++)
					dp[j]+=dp[j+k]/6;
				dp[j]+=1;
			}
			dp[j]=dp[book[i].y];
			j--;
		}
		for(;j>=0;j--)
		{
			for(k=1;k<=6;k++)
				dp[j]+=dp[j+k]/6;
			dp[j]+=1;
		}
		printf("%.4lf\n",dp[0]);
		memset(dp,0,sizeof dp);
	}
}




猜你喜欢

转载自blog.csdn.net/greybtfly/article/details/80533320