POJ - 1860 ——Currency Exchange【最短路】

Currency Exchange
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 34978   Accepted: 13415

Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency. 
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR. 
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real R AB, C AB, R BA and C BA - exchange rates and commissions when exchanging A to B and B to A respectively. 
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations. 

Input

The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10 3
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10 -2<=rate<=10 2, 0<=commission<=10 2
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10 4

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES

Source

Northeastern Europe 2001, Northern Subregion

[Submit]   [Go Back]   [Status]   [Discuss]

Home Page   Go Back  To top


All Rights Reserved 2003-2013 Ying Fuchen,Xu Pengcheng,Xie Di

Any problem, Please Contact Administrator

最短路模板题,求最大值问题,dis初始化的时候稍微变一下就行了。

#include<cstdio>
#include<algorithm>
#include<iostream>
#include<queue>
#include<cstring>
#define INF 0x3f3f3f3f
using namespace std;

const int MAXN=100005;
double dis[MAXN],r1[MAXN],c1[MAXN],r2[MAXN],c2[MAXN],v;
int n,m,s,vis[MAXN],a[MAXN],b[MAXN],head[MAXN],top;

struct node{
	int to,next;
	double w1,w2;//w1为汇率,w2为佣金 
}e[MAXN+100];

void addEdge(int u,int v,double cost1,double cost2){
	e[top].to=v;
	e[top].next=head[u];
	e[top].w1=cost1;
	e[top].w2=cost2;
	head[u]=top++;	
}

int spfa(int s){
	memset(dis,0,sizeof(dis));
	dis[s]=v;//初始值为v
	memset(vis,0,sizeof(vis));
	vis[s]=1;
	queue<int> q;
	q.push(s);
	while(!q.empty()){
		int x=q.front();
		q.pop();
		vis[x]=0;
		for(int i=head[x];i!=-1;i=e[i].next){
			int j=e[i].to;
			double k=e[i].w1,r=e[i].w2;
			if(dis[j]<(dis[x]-r)*k){
				dis[j]=(dis[x]-r)*k;
				if(!vis[j]){
					q.push(j);
					vis[j]=1;
				}
			}
		}
	}
	if(dis[s]>v) return 1;
	else return 0;
}

int main(){
	while(~scanf("%d%d%d%lf",&n,&m,&s,&v)){
		int i;
		memset(head,-1,sizeof(head));
		top=0;
		for(i=1;i<=m;i++){
			scanf("%d%d%lf%lf%lf%lf",&a[i],&b[i],&r1[i],&c1[i],&r2[i],&c2[i]);
			addEdge(a[i],b[i],r1[i],c1[i]);
			addEdge(b[i],a[i],r2[i],c2[i]);
		}
		int ans=spfa(s);
		if(ans) printf("YES\n");
		else printf("NO\n");
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/xiang_hehe/article/details/80386936