PO1068 Parencodings 模拟题

Parencodings
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 28860   Accepted: 16997

Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways: 
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence). 
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence). 

Following is an example of the above encodings: 

S (((()()())))
P-sequence 4 5 6666
W-sequence 1 1 1456

Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string. 

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9

从别人的博客上学的:
https://www.cnblogs.com/--ZHIYUAN/p/5910981.html

#include<iostream>
#include<string>
#include<cstdio>
using namespace std;
int main(){
    int n,T;
    scanf("%d",&T);
    while(T--){
        int q1,q2 = 0;
        string s;
        scanf("%d",&n);
        for(int i = 0; i < n; i++){
            scanf("%d",&q1);
            q2 = q1 - q2;
            while(q2--)
                s += "(";
            s += ")";
            q2 = q1;
        }
        int num = s.length();
        int cnt = 0;
        int sum;
        for(int i = 0; i < num; i++){
            if(s[i] == ')'){
                cnt++;
                int flag = 1;
                sum = 0;
                for(int j = i - 1; j >= 0; j--){
                    if(flag == 0)
                        break;
                    if(s[j] == ')'){
                        flag += 1;
                    }
                    else if(s[j] == '('){
                        flag -= 1;
                        sum++;
                    }
                }
                if(cnt != n)
                    printf("%d ",sum);
                else
                    printf("%d\n",sum);
            }
            
        }
    }
    return 0;
}
View Code

猜你喜欢

转载自www.cnblogs.com/Weixu-Liu/p/10422650.html