Parencodings

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways: 
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence). 
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence). 

Following is an example of the above encodings: 

	S		(((()()())))

	P-sequence	    4 5 6666

	W-sequence	    1 1 1456


Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string. 
Input
The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.
Output
The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.
Sample Input
2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9
Sample Output
1 1 1 4 5 6
1 1 2 4 5 1 1 3 9
#include<stdio.h>
#include<string.h>
int main()
{
    int m,n,a[50],i,j,k,s,flag,b[50],book[50];
    scanf("%d",&m);
    while(m--)
    {
        scanf("%d",&n);
        memset(book,0,sizeof(book));
        j = 1,s = flag = 0;
        for(i = 1; i <= n; i++)
            scanf("%d",&a[i]);                    //输入的a[i]数值表示前面有几个左括号
        a[0] = 0;
        for(i = 1;i <= n; i++)                    //表示输入的n组数据
        {
            if(a[i] == a[i-1])
                b[j++] = 0;                       //将右括号标记为0
            else
            {
                for(k = 1; k <= a[i]-a[i-1];k++)  //k表示前一个右括号和本身的距离相差几
                    b[j++] = 1;                   //将左括号标记为1
                b[j++] = 0;                       //将自己本身标记为0
            }
        }
        for(i = a[1] + 1; i <= 2*n;i++)           //从第一个右括号开始找
        {
            if(b[i] == 0)                         //找到右括号
            {
                s = 1;                             //表示这组括号带本身总共包含几个括号
                for(k = i - 1; k >= 1; k--)
                {
                    if(!book[k] && b[k] == 1)       //找到一个没有用过的左括号
                    {
                        book[k] = 1;                //标记,表示此左括号以用过
                        if(!flag)
                        {
                            printf("%d",s);         //控制输出格式
                            flag  = 1;
                        }
                        else
                            printf(" %d",s);
                        break;
                    }
                    if(book[k])                      //表示组成一个括号,经过几组成对的括号
                        s++;
                }
            }
        }
        printf("\n");
    }
    return 0;
}




    


猜你喜欢

转载自blog.csdn.net/Qin7_Victory/article/details/72453514