Parencodings POJ-1068 解题报告

POJ-1068

Parencodings
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 28039   Accepted: 16495

Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways: 
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence). 
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence). 

Following is an example of the above encodings: 
	S		(((()()())))

	P-sequence	    4 5 6666

	W-sequence	    1 1 1456


Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string. 

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9

Source


解题思路:

题目是跟着POJ分类很好很有层次感来做的,来源:点击打开链接

虽然这题被分到模拟里,但是还是有明显的规律的

现实题意,一串左右括号,分别由两种表示形式:

第一种:第i项表示第i个右括号在第几个左括号后

第二中:第i项表示与第i个右括号相匹配的左括号是他前面的几个左括号

输入为第一种表示方法,要求你输入第二种表示方法


那么规律就很明显,第一中表示方法的最后一个数是最大数,也就代表着有多少个右括号,那么同时也就有多少个左括号

想要转化成第二种表示方式只要从每一个右括号开始向前数左括号了

因为左括号一定在右括号前面,那么从第i个左括号开始,遍历到第1个左括号,如果最大数的左括号没有标记成为以匹配,那么就将遍历个数存到结果中,并将其标记。否则就继续遍历。


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

bool map[30];
int p[30];
int result[30];

int main()
{
	int T;
	scanf ("%d",&T);
	getchar();
	
	while (T--)
	{
		memset(map,0,sizeof(map));
		int size;
		scanf ("%d",&size);
		getchar();
		
		for (int i=1;i<=size;++i)	
			scanf("%d",&p[i]); 
		getchar();
		
		for (int i=1;i<=size;++i)	{
			int sumfind = 1;
			for (int j=p[i];j>=1;--j)	{
				if(!map[j])	{
					result[i]=sumfind;
					map[j]=1;
					break;
				}
				else sumfind++;	
			}
		}
		
		for (int i=1;i<size;++i)
			printf("%d ",result[i]);
		printf("%d\n",result[size]);
		
	}
	
	return 0;
}

猜你喜欢

转载自blog.csdn.net/sang749992462/article/details/80302329
今日推荐