【POJ1068】Parencodings(模拟)

题目链接

Parencodings

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions:28556   Accepted: 16825

Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways: 
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence). 
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence). 

Following is an example of the above encodings: 

	S		(((()()())))

	P-sequence	    4 5 6666

	W-sequence	    1 1 1456


Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string. 

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9

Source

Tehran 2001

【题意】

给出一个序列P,代表每一个右括号前的左括号数目,要求输出序列W,即每个右括号前能匹配的括号数目。

【解题思路】

用数组b记录每两个右括号之间的左括号数目,然后依次匹配即可。

【代码】

#include<cstdio>
#include<cstring>
using namespace std;
int a[50],b[50],ans[50];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n;
        scanf("%d",&n);
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        memset(ans,0,sizeof(ans));
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        b[0]=a[1];
        for(int i=1;i<n;i++)
            b[i]=a[i+1]-a[i];
        for(int i=1;i<=n;i++)
        {
            int j;
            for(j=i-1;j>=0;j--)
            {
                if(b[j]>0)
                {
                    b[j]--;
                    break;
                }
            }
            if(j>=0)ans[i]=i-j;
            else ans[i]=0;
        }
        for(int i=1;i<=n;i++)
            i==1?printf("%d",ans[i]):printf(" %d",ans[i]);
        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_39826163/article/details/83041494