05-树8 File Transfer (25 分

We have a network of computers and a list of bi-directional connections. Each of these connections allows a file transfer from one computer to another. Is it possible to send a file from any computer on the network to any other?

Input Specification:

Each input file contains one test case. For each test case, the first line contains N (2N104​​), the total number of computers in a network. Each computer in the network is then represented by a positive integer between 1 and N. Then in the following lines, the input is given in the format:

I c1 c2  

where I stands for inputting a connection between c1 and c2; or

C c1 c2    

where C stands for checking if it is possible to transfer files between c1 and c2; or

S

where S stands for stopping this case.

Output Specification:

For each C case, print in one line the word "yes" or "no" if it is possible or impossible to transfer files between c1 and c2, respectively. At the end of each case, print in one line "The network is connected." if there is a path between any pair of computers; or "There are k components." where k is the number of connected components in this network.

Sample Input 1:

5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
S

Sample Output 1:

no
no
yes
There are 2 components.

Sample Input 2:

5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
I 1 3
C 1 5
S

Sample Output 2:

no
no
yes
yes
The network is connected.
#include<cstdio>
const int maxn = 10001;
typedef int ElementType;
typedef int setName;
typedef int setType[maxn];

int Find(setType S,ElementType X){
    if(S[X] < 0) return X;
    else return S[X] = Find(S,S[X]); 
}

void Input_connection(setType S){
    ElementType u,v;
    setName root1,root2;
    scanf("%d %d\n",&u,&v);
    root1 = Find(S,u-1);
    root2 = Find(S,v-1);
    if(root1 != root2) S[root1] = root2;
}

void Check_connection(setType S){
    ElementType u,v;
    setName root1,root2;
    scanf("%d %d\n",&u,&v);
    root1 = Find(S,u-1);
    root2 = Find(S,v-1);
    if(root1 != root2) printf("no\n");
    else printf("yes\n");
}

void Check_network(setType S,int n){
    int counter = 0;
    for(int i = 0; i < n; i++){
        if(S[i] < 0) counter++;
    }
    if(counter == 1) printf("The network is connected.\n");
    else printf("There are %d components.\n",counter);
}

void Initialization(setType S,int n){
    for(int i = 0; i < n; i++){
        S[i] = -1;
    }
}

//void check(setType S,int n){
//    for(int i = 0 ; i < n; i++){
//        printf("%d ",S[i]);
//    }
//} 

int main(){
    setType S;
    int n;
    char in;
    scanf("%d\n",&n);
    Initialization(S,n);
    do{
        scanf("%c",&in);
        switch(in){
            case 'I':Input_connection(S);break;
            case 'C':Check_connection(S);break;
            case 'S':Check_network(S,n);break;
        }
    //check(S,n);
    }while(in != 'S');
    return 0;
}
 

猜你喜欢

转载自www.cnblogs.com/wanghao-boke/p/10409329.html