树8 File Transfer

We have a network of computers and a list of bi-directional connections. Each of these connections allows a file transfer from one computer to another. Is it possible to send a file from any computer on the network to any other?

Input Specification:

Each input file contains one test case. For each test case, the first line contains N (2≤N≤10​4​​), the total number of computers in a network. Each computer in the network is then represented by a positive integer between 1 and N. Then in the following lines, the input is given in the format:

I c1 c2  

where I stands for inputting a connection between c1 and c2; or

C c1 c2    

where C stands for checking if it is possible to transfer files between c1 and c2; or

S

where S stands for stopping this case.

Output Specification:

For each C case, print in one line the word "yes" or "no" if it is possible or impossible to transfer files between c1 and c2, respectively. At the end of each case, print in one line "The network is connected." if there is a path between any pair of computers; or "There are k components." where k is the number of connected components in this network.

Sample Input 1:

5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
S

Sample Output 1:

no
no
yes
There are 2 components.

Sample Input 2:

5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
I 1 3
C 1 5
S

Sample Output 2:

no
no
yes
yes
The network is connected.
#include<iostream>
using namespace std;
#define MAXSize 10001
typedef int ElementType;
typedef int SetName;
typedef ElementType SetType[MAXSize];
void Initialization(SetType s, int n) {
	for (int i = 0; i < n; i++)
	{
		s[i] = -1;
	}
}
SetName Find(SetType s, ElementType x) {
	if (s[x] < 0) return x;
	else return s[x] = Find(s, s[x]);
}
void Union(SetType s, int root1, int root2) {
	if (s[root1] < s[root2])
		s[root2] = root1; 
	else
	{
		if (s[root1] == s[root2]) s[root2]--;
		s[root1] = root2;
	}
}
void INput_connection(SetType s) {
	ElementType a, b;
	SetName root1, root2;
	cin >> a >> b;
	root1 = Find(s, a-1);
	root2 = Find(s, b-1);
	if (root1!=root2)
	{
		Union(s, root1, root2);
	}
}
void Check_connection(SetType s) {
	ElementType a, b;
	SetName root1, root2;
	cin >> a >> b;
	root1 = Find(s, a-1);
	root2 = Find(s, b-1);
	if (root1 == root2) cout << "yes" << endl;
	else cout <<"no" << endl;
}
void Check_network(SetType s, int n) {
	int i, num=0;
	for ( i = 0; i < n; i++)
	{
		if (s[i] < 0)  num++;
	}
	if (num == 1)
		cout << "The network is connected." << endl;
	else
		cout << "There are" << ' ' << num << " components." << endl;
}
int main()
{
	SetType s;
	int n;
	char in;
	cin >> n;
	Initialization(s, n);
	do
	{
		cin >> in;
		switch (in)
		{
		case'I': INput_connection(s);  break;
		case'C': Check_connection(s);	break;
		case'S': Check_network(s, n); break;
		}
	} while (in!='S');
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41345173/article/details/82961517