7-8 File Transfer

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/Authur520/article/details/84837984

We have a network of computers and a list of bi-directional connections. Each of these connections allows a file transfer from one computer to another. Is it possible to send a file from any computer on the network to any other?

Input Specification:

Each input file contains one test case. For each test case, the first line contains N (2≤N≤10 4 ), the total number of computers in a network. Each computer in the network is then represented by a positive integer between 1 and N. Then in the following lines, the input is given in the format:

I c1 c2  

where I stands for inputting a connection between c1 and c2; or

C c1 c2    

where C stands for checking if it is possible to transfer files between c1 and c2; or

S

where S stands for stopping this case.

Output Specification:

For each C case, print in one line the word "yes" or "no" if it is possible or impossible to transfer files between c1 and c2, respectively. At the end of each case, print in one line "The network is connected." if there is a path between any pair of computers; or "There are k components." where k is the number of connected components in this network.

Sample Input 1:

5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
S

Sample Output 1:

no
no
yes
There are 2 components.

Sample Input 2:

5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
I 1 3
C 1 5
S

Sample Output 2:

no
no
yes
yes
The network is connected.
#include<stdio.h>

#define MaxSize 10005                  /* 集合最大元素个数 */

typedef int ElementType;           /* 默认元素可以用非负整数表示 */
typedef int SetName;               /* 默认用根结点的下标作为集合名称 */
typedef ElementType SetType[MaxSize]; /* 假设集合元素下标从0开始 */
 
void Initialization(SetType S,int n); 
void Input_connection(SetType S);
void Check_connection(SetType S);
void Check_network(SetType S,int n);

 
int main()
{
	int n;
	char in;
	SetType S;
	
	scanf("%d",&n);
	Initialization(S,n);
	do{
		scanf("%c",&in);
		switch(in){
			case 'I':Input_connection(S);break;
			case 'C':Check_connection(S);break;
			case 'S':Check_network(S,n);break;
		}
	}while(in != 'S');
	
	return 0;
 } 
 
void Initialization(SetType S,int n)
{
	for(int i=0; i<n; i++){
		S[i] = -1;  //集合里面的元素都没有父亲结点,可以全看作根结点,所以父亲指针全为-1 
	}
}
 
SetName Find( SetType S, ElementType X )
{ /* 默认集合元素全部初始化为-1 */
    for(; S[X]>=0; X=S[X]);
    /*或者下面这段代码*/
//	if(S[X] < 0){
//		return X;  //找到了,返回根结点 
//	}else{
//		return S[X] = Find(S,S[X]);  //路径压缩 
//	}
    
    return X;
}
 
void Union( SetType S, SetName Root1, SetName Root2 )
{ /* 这里默认Root1和Root2是不同集合的根结点 */
    /* 保证小集合并入大集合 */
    if ( S[Root2] < S[Root1] ) { /* 如果集合2比较大 */
        S[Root2] += S[Root1];     /* 集合1并入集合2  */
        S[Root1] = Root2;
    }
    else {                         /* 如果集合1比较大 */
        S[Root1] += S[Root2];     /* 集合2并入集合1  */
        S[Root2] = Root1;
    }
    /*或者下面这段代码也行*/
//    if ( S[Root2] < S[Root1] ) { /* 如果集合2形成的树高 */
//        S[Root1] = Root2;     /* 集合1并入集合2  */
//    }
//    else {                         /* 如果集合1形成的树高 */
//        if ( S[Root2] == S[Root1] )  S[Root1]--;  //树等高,树高++   
//        S[Root2] = Root1;        /* 集合2并入集合1  */
//    }
}

void Input_connection(SetType S)
{
	ElementType u,v;
	SetName root1,root2;
	
	scanf("%d %d",&u,&v);
	root1 = Find(S,u-1);
	root2 = Find(S,v-1);
	if(root1 != root2)
	    Union(S,root1,root2);
 } 
 
void Check_connection(SetType S)
{
	ElementType u,v;
	SetName root1,root2;
	
	scanf("%d %d",&u,&v);
	root1 = Find(S,u-1);
	root2 = Find(S,v-1);
	if(root1 == root2){
		printf("yes\n");
	}else{
		printf("no\n");
	}
}

void Check_network(SetType S,int n)
{
	int cnt = 0;
	
	for(int i=0; i<n; i++){
		if(S[i] < 0)  cnt++;
	}
	if(cnt == 1){
		printf("The network is connected.\n");
	}else{
		printf("There are %d components.\n",cnt);
	}
}

猜你喜欢

转载自blog.csdn.net/Authur520/article/details/84837984