PTA 中国大学MOOC-陈越、何钦铭-数据结构-2018秋 05-树8 File Transfer (25 分) 并查集

We have a network of computers and a list of bi-directional connections. Each of these connections allows a file transfer from one computer to another. Is it possible to send a file from any computer on the network to any other?

Input Specification:

Each input file contains one test case. For each test case, the first line contains N (2≤N≤10​4​​), the total number of computers in a network. Each computer in the network is then represented by a positive integer between 1 and N. Then in the following lines, the input is given in the format:

I c1 c2  

where I stands for inputting a connection between c1 and c2; or

C c1 c2    

where C stands for checking if it is possible to transfer files between c1 and c2; or

S

where S stands for stopping this case.

Output Specification:

For each C case, print in one line the word "yes" or "no" if it is possible or impossible to transfer files between c1 and c2, respectively. At the end of each case, print in one line "The network is connected." if there is a path between any pair of computers; or "There are k components." where k is the number of connected components in this network.

Sample Input 1:

5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
S

Sample Output 1:

no
no
yes
There are 2 components.

Sample Input 2:

5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
I 1 3
C 1 5
S

Sample Output 2:

no
no
yes
yes
The network is connected.

 代码如下:

/*
并查集的查找与合并
一开始初始化集合的个数为n个..
然后每两个集合合并就将集合数减一..
最后判断集合个数是否为一来判定是否两两相互连接...
*/
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
const int maxn=10005;
int n;
int a[maxn];
int num;
char op[5];
void init()
{
    num=n;
    for (int i=1;i<=n;i++)
    {
        a[i]=i;
    }
}
int Find(int x)
{
    if(a[x]==x)
        return x;
    else
        return a[x]=Find(a[x]);
}
void unit(int x,int y)
{
    int px=Find(x);
    int py=Find(y);
    if(px!=py)
    {
       a[px]=py;
       num--;
    }
}
int main()
{
    scanf("%d",&n);
    init();
    while (scanf("%s",op)&&op[0]!='S')
    {
        int x,y;
        scanf("%d%d",&x,&y);
        if(op[0]=='I')
        {
           unit(x,y);
        }
        else
        {
            if(Find(x)==Find(y))
            {
                printf("yes\n");
            }
            else
              printf("no\n");
        }
    }
    if(num==1)
        printf("The network is connected.\n");
    else
        printf("There are %d components.\n",num);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41410799/article/details/82953134