05-树8 File Transfer 并查集(C++)

We have a network of computers and a list of bi-directional connections. Each of these connections allows a file transfer from one computer to another. Is it possible to send a file from any computer on the network to any other?

Input Specification:

Each input file contains one test case. For each test case, the first line contains N (2≤N≤104), the total number of computers in a network. Each computer in the network is then represented by a positive integer between 1 and N. Then in the following lines, the input is given in the format:

I c1 c2  

where I stands for inputting a connection between c1 and c2; or

C c1 c2    

where C stands for checking if it is possible to transfer files between c1 and c2; or

S

where S stands for stopping this case.

Output Specification:

For each C case, print in one line the word "yes" or "no" if it is possible or impossible to transfer files between c1 and c2, respectively. At the end of each case, print in one line "The network is connected." if there is a path between any pair of computers; or "There are k components." where k is the number of connected components in this network.

Sample Input 1:

5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
S

Sample Output 1:

no
no
yes
There are 2 components.

Sample Input 2:

5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
I 1 3
C 1 5
S

Sample Output 2:

no
no
yes
yes
The network is connected.

code

# include <iostream>
# include <cstdio>

struct set {
	int n;
	int * root;
	set(int _n):n(_n)
	{
		root = new int[n+1];
		for (int i = 1; i <= n; ++i) root[i] = -1;
	}

	void u(int a, int b) //并
	{
		root[f(a)] = f(b);
	}

	bool f(int a, int b) //查
	{
		return f(a) == f(b);
	}

	int f(int a) //查根
	{
		if (root[a] == -1) return a;
		return root[a] = f(root[a]);
	}

	int s(void)
	{
		int ans = 0;
		for (int i = 1; i <= n; ++i)
		{
			if (root[i] == -1) ans++;
		}
		return ans;
	}
};

int main(void)
{
	int n;
	scanf("%d", &n);
	char op;
	set s(n);
	do
	{
		int a, b;
		scanf("\n%c", &op);
		switch (op)
		{
		case 'C':
			scanf("%d%d", &a, &b);
			if (s.f(a, b)) printf("yes\n");
			else printf("no\n");
			break;

		case 'I':
			scanf("%d%d", &a, &b);
			s.u(a, b);
			break;

		case 'S':
			int tmp = s.s();
			if (tmp == 1) printf("The network is connected.\n");
			else printf("There are %d components.\n", tmp);

		}
	} while (op != 'S');

	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_45339670/article/details/132000607