1142 Maximal Clique (25 分)图

1142 Maximal Clique (25 分)

A clique is a subset of vertices of an undirected graph such that every two distinct vertices in the clique are adjacent. A maximal clique is a clique that cannot be extended by including one more adjacent vertex. (Quoted from https://en.wikipedia.org/wiki/Clique_(graph_theory))

Now it is your job to judge if a given subset of vertices can form a maximal clique.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers Nv (≤ 200), the number of vertices in the graph, and Ne, the number of undirected edges. Then Ne lines follow, each gives a pair of vertices of an edge. The vertices are numbered from 1 to Nv.

After the graph, there is another positive integer M (≤ 100). Then M lines of query follow, each first gives a positive number K (≤ Nv), then followed by a sequence of K distinct vertices. All the numbers in a line are separated by a space.

Output Specification:

For each of the M queries, print in a line Yes if the given subset of vertices can form a maximal clique; or if it is a clique but not a maximal clique, print Not Maximal; or if it is not a clique at all, print Not a Clique.

Sample Input:

8 10
5 6
7 8
6 4
3 6
4 5
2 3
8 2
2 7
5 3
3 4
6
4 5 4 3 6
3 2 8 7
2 2 3
1 1
3 4 3 6
3 3 2 1

Sample Output:

Yes
Yes
Yes
Yes
Not Maximal
Not a Clique
思路:
  题目大意是给定一个顶点数组,
               1)如果该数组内的点之间不是两两直接连接,输出Not a Clique
               2)如果1)为真,判断给出的数组是否是最大,如果是输出Yes,不是
  输出Not Maximal。
  根据题意使用邻接矩阵进行存储图(这样判断两个顶点之间是否直接连接很方便)。
#include<iostream>
#include<vector>
#include<algorithm>
#include<queue>
#include<string>
#include<map>
#include<set>
#include<stack>
#include<string.h>
#include<cstdio>
#include<cmath>
using namespace std;

int graph[201][201];

void judge(int a[],int k,int n)
{
    bool visited[n+1];
    fill(visited,visited+n+1,true);

    for(int i=0;i<k;i++)
    {

        int temp1=a[i];
        visited[temp1]=false;
        for(int j=i+1;j<k;j++)
        {
            int temp2=a[j];
            if(graph[temp1][temp2]==0)
            {
                printf("Not a Clique\n");
                return;
            }
        }
    }
    for(int i=1;i<n+1;i++)
    {
        if(visited[i])
        {
            bool flag=true;
            for(int j=0;j<k;j++)
            {
                if(graph[i][a[j]]==0)
                    flag=false;
            }
            if(flag)
            {
                printf("Not Maximal\n");
                return;
            }
        }
    }

    printf("Yes\n");


}


int main()
{
    int n,m;
    cin>>n>>m;
   // graph.resize(n+1);
    for(int i=0;i<m;i++)
    {
        int start,endL;
        cin>>start>>endL;
        //graph[start].push_back(start);
        graph[start][endL]=1;
        graph[endL][start]=1;
       // graph[endL].push_back(endL);
    }
    cin>>m;
    for(int i=0;i<m;i++)
    {
        int k;
        cin>>k;
        int temp[k];
        for(int j=0;j<k;j++)
        {
           int a;
           cin>>a;
            temp[j]=a;
        }
        judge(temp,k,n);
    }

    return 0;
}
 
 

猜你喜欢

转载自www.cnblogs.com/zhanghaijie/p/10323421.html
今日推荐