1142. Maximal Clique (25) 图

1142. Maximal Clique (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

clique is a subset of vertices of an undirected graph such that every two distinct vertices in the clique are adjacent. A maximal clique is a clique that cannot be extended by including one more adjacent vertex. (Quoted from https://en.wikipedia.org/wiki/Clique_(graph_theory))

Now it is your job to judge if a given subset of vertices can form a maximal clique.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers Nv (<= 200), the number of vertices in the graph, and Ne, the number of undirected edges. Then Ne lines follow, each gives a pair of vertices of an edge. The vertices are numbered from 1 to Nv.

After the graph, there is another positive integer M (<= 100). Then M lines of query follow, each first gives a positive number K (<= Nv), then followed by a sequence of K distinct vertices. All the numbers in a line are separated by a space.

Output Specification:

For each of the M queries, print in a line "Yes" if the given subset of vertices can form a maximal clique; or if it is a clique but not a maximal clique, print "Not Maximal"; or if it is not a clique at all, print "Not a Clique".

Sample Input:
8 10
5 6
7 8
6 4
3 6
4 5
2 3
8 2
2 7
5 3
3 4
6
4 5 4 3 6
3 2 8 7
2 2 3
1 1
3 4 3 6
3 3 2 1
Sample Output:
Yes
Yes
Yes
Yes
Not Maximal
Not a Clique

        给出一个图和一组顶点,如果这些点在图中两两之间都直接相连,则输出Yes或者Not Maximal,进一步如果图中还有其他点可以与这组每个顶点两两相连,则输出Not Maximal,否则输出Yes。

        输入的时候检查组内之间点的连接情况。之后检查图中其他点的情况。数据不大,暴力一点一个一个检查就可以了


#include <cstdio>
#include <set>
#include <algorithm>

using namespace std;

int Nv, Ne, M, K;
int mp[201][201];
int vis[501];

int checkk(int now, set<int>&s1) {
	for (auto it = s1.begin(); it != s1.end(); it++) {
		if (mp[now][*it] == 0) {
			printf("Not a Clique\n");
			return 0;
		}
	}
	return 1;
}

int main() {
	int a, b;
	scanf("%d %d", &Nv, &Ne);
	for (int i = 0; i < Ne; i++) {
		scanf("%d %d", &a, &b);
		mp[a][b] = mp[b][a] = 1;
		mp[a][a] = mp[b][b] = 1;
	}
	scanf("%d", &M);
	for (int i = 0; i < M; i++) {
		scanf("%d", &K);
		fill(vis, vis + 501, 0);
		set<int>s1;
		int t;
		int f = 1;
		for (int j = 0; j < K; j++) {
			scanf("%d", &t);
			if (f) {
				vis[t] = 1;
				f = checkk(t, s1);
				s1.insert(t);
			}
		}
		if (f) {
			int f3 = 1;
			for (int j = 1; j <= Nv; j++) {
				if (vis[j] == 0) {
					int f2 = 1;
					for (auto it = s1.begin(); it != s1.end(); it++) {
						if (mp[j][*it] == 0) {
							f2 = 0;
							break;
						}
					}
					if (f2) {
						printf("Not Maximal\n");
						f3 = 0;
						break;
					}
				}
			}
			if (f3)printf("Yes\n");
		}
	}
	return 0;
}

原创文章 59 获赞 41 访问量 10万+

猜你喜欢

转载自blog.csdn.net/rzdyzx/article/details/79665961