PAT 1142 Maximal Clique(25 分)

clique is a subset of vertices of an undirected graph such that every two distinct vertices in the clique are adjacent. A maximal clique is a clique that cannot be extended by including one more adjacent vertex. (Quoted from https://en.wikipedia.org/wiki/Clique_(graph_theory))

Now it is your job to judge if a given subset of vertices can form a maximal clique.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers Nv (≤ 200), the number of vertices in the graph, and Ne, the number of undirected edges. Then Ne lines follow, each gives a pair of vertices of an edge. The vertices are numbered from 1 to Nv.

After the graph, there is another positive integer M (≤ 100). Then M lines of query follow, each first gives a positive number K (≤ Nv), then followed by a sequence of K distinct vertices. All the numbers in a line are separated by a space.

Output Specification:

For each of the M queries, print in a line Yes if the given subset of vertices can form a maximal clique; or if it is a clique but not a maximal clique, print Not Maximal; or if it is not a clique at all, print Not a Clique.

Sample Input:

8 10
5 6
7 8
6 4
3 6
4 5
2 3
8 2
2 7
5 3
3 4
6
4 5 4 3 6
3 2 8 7
2 2 3
1 1
3 4 3 6
3 3 2 1

Sample Output:

Yes
Yes
Yes
Yes
Not Maximal
Not a Clique

 思路:模拟题,判断给出的点集是否满足团的条件。

程序:

#include <iostream>
#include <cstdio>
#include <vector>
#include <algorithm>
using namespace std;
int arr[201][201];
int n,m;
void func(vector<int> v)
{
  bool isClique = true;
  for(int i = 0; i < v.size(); i++)
  {
    for(int j = i+1; j < v.size(); j++)
    {
      if(arr[v[i]][v[j]] != 1)
      {
        isClique = false;
        printf("Not a Clique\n");
        return;
      }
    }
  }
  bool isMaximal = true;
  if(isClique)
  {
    for(int i = 1; i <= n; i++)
    {
      bool isExist = false;
      for(int k = 0; k < v.size(); k++)
      {
        if(v[k] == i)
        {
          isExist = true;
          break;
        }
      }
      if(!isExist)
      {
        bool isAllConnected = true;
        for(int j = 0; j < v.size(); j++)
        {
          if(arr[i][v[j]] != 1)
          {
            isAllConnected = false;
          }
        }
        if(isAllConnected)
        {
          isMaximal = false;
          printf("Not Maximal\n");
          return;
        }
      }
    }
  }
  if(isMaximal)
    printf("Yes\n");
}
int main()
{
  scanf("%d%d",&n,&m);
  for(int i = 0; i < m; i++)
  {
    int a,b;
    scanf("%d%d",&a,&b);
    arr[a][b] = arr[b][a] = 1;
  }
  int p;
  scanf("%d",&p);
  for(int i = 0; i < p; i++)
  {
    int k;
    scanf("%d",&k);
    vector<int> v;
    for(int j = 0; j < k; j++)
    {
      int num;
      scanf("%d",&num);
      v.push_back(num);
    }
    func(v);
  }
  return 0;
}

猜你喜欢

转载自blog.csdn.net/Hickey_Chen/article/details/81200920