1142 Maximal Clique(25 分)

1142 Maximal Clique(25 分)

A clique is a subset of vertices of an undirected graph such that every two distinct vertices in the clique are adjacent. A maximal clique is a clique that cannot be extended by including one more adjacent vertex. (Quoted from https://en.wikipedia.org/wiki/Clique_(graph_theory))

Now it is your job to judge if a given subset of vertices can form a maximal clique.
Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers Nv (≤ 200), the number of vertices in the graph, and Ne, the number of undirected edges. Then Ne lines follow, each gives a pair of vertices of an edge. The vertices are numbered from 1 to Nv.

After the graph, there is another positive integer M (≤ 100). Then M lines of query follow, each first gives a positive number K (≤ Nv), then followed by a sequence of K distinct vertices. All the numbers in a line are separated by a space.
Output Specification:

For each of the M queries, print in a line Yes if the given subset of vertices can form a maximal clique; or if it is a clique but not a maximal clique, print Not Maximal; or if it is not a clique at all, print Not a Clique.
Sample Input:

8 10
5 6
7 8
6 4
3 6
4 5
2 3
8 2
2 7
5 3
3 4
6
4 5 4 3 6
3 2 8 7
2 2 3
1 1
3 4 3 6
3 3 2 1

Sample Output:

Yes
Yes
Yes
Yes
Not Maximal
Not a Clique

#include<bits/stdc++.h>
#include<iostream>
using namespace std;
int way[300][300];
int a[300];
bool check(int x,int k){
    if(x != -1) a[k++] = x;
    for(int i = 0; i < k; i++){
        for(int j = i + 1; j < k; j++){
            if(way[a[i]][a[j]] == 0){
                return false;
            }
        }
    }
    return true;
}
int main(){
    int n,m;
    cin >> n >> m;
    for(int i = 0; i < m; i++){
        int a,b;
        cin >> a >> b;
        way[a][b] = way[b][a] = 1;
    }
    int k;
    cin >> k;
    while(k--){
        int num;
        cin >> num;
        for(int i = 0; i < num; i++){
            cin >> a[i];
        }
        if(!check(-1,num)){
            cout << "Not a Clique" << endl;
            continue;
        }
        for(int i = 1; i <= n; i++){
            int flag = 0;
            for(int j = 0; j < num; j++){
                if(way[a[j]][i] == 1){
                    flag = 1;
                    break;
                }
            }
            if(flag){
                if(check(i,num)){
                    cout << "Not Maximal" << endl;
                    goto out;
                }
            }
        }
        cout << "Yes" << endl;
        out:;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_39557517/article/details/81874696