PAT Advanced 1142. Maximal Clique (25)

问题描述:

1142. Maximal Clique (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

clique is a subset of vertices of an undirected graph such that every two distinct vertices in the clique are adjacent. A maximal clique is a clique that cannot be extended by including one more adjacent vertex. (Quoted from https://en.wikipedia.org/wiki/Clique_(graph_theory))

Now it is your job to judge if a given subset of vertices can form a maximal clique.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers Nv (<= 200), the number of vertices in the graph, and Ne, the number of undirected edges. Then Ne lines follow, each gives a pair of vertices of an edge. The vertices are numbered from 1 to Nv.

After the graph, there is another positive integer M (<= 100). Then M lines of query follow, each first gives a positive number K (<= Nv), then followed by a sequence of K distinct vertices. All the numbers in a line are separated by a space.

Output Specification:

For each of the M queries, print in a line "Yes" if the given subset of vertices can form a maximal clique; or if it is a clique but not a maximal clique, print "Not Maximal"; or if it is not a clique at all, print "Not a Clique".

Sample Input:
8 10
5 6
7 8
6 4
3 6
4 5
2 3
8 2
2 7
5 3
3 4
6
4 5 4 3 6
3 2 8 7
2 2 3
1 1
3 4 3 6
3 3 2 1
Sample Output:
Yes
Yes
Yes
Yes
Not Maximal
Not a Clique


纪念一下3月18日PAT满分×3

这一题因为是验证性程序,所以可以暴力循环解决。。。

AC代码:

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
#include<bits/stdc++.h>
using namespace std;
int main()
{
//	freopen("data3.txt","r",stdin);
	ios::sync_with_stdio(false);
	int n,m,c1,c2,k;
	cin>>n>>m;
	set<pair<int,int> > s;
	pair<int,int> p;
	for(;m--;)
	{
		cin>>p.first>>p.second;
		if(p.first>p.second)
		swap(p.first,p.second);
		s.insert(p);
	}
	cin>>m;
	for(;m--;)
	{
		cin>>k;
		bool flag=true;
		vector<bool> vb(n+1,true);
		vector<int> v;
		for(;k--;)
		{
			cin>>c2;
			for(auto i:v)
			{
				p.first=min(i,c2);
				p.second=max(i,c2);
				if(s.find(p)==s.end())
				{
					flag=false;
					break;
				}
			}
			v.push_back(c2);
			vb[c2]=false;
		}
		if(flag)
		{
			bool flagg=true;
			for(int i=1;i<=n&&flagg;i++)
			{
				if(vb[i])
				{
					bool flaggg=true;
					for(int j=0;j<v.size()&&flaggg;j++)
					{
						p.first=min(v[j],i);
						p.second=max(v[j],i);
						if(s.find(p)==s.end())
						flaggg=false;
					}
					if(flaggg)
					flagg=false;
				}
			}
			if(flagg)
			cout<<"Yes\n";
			else
			cout<<"Not Maximal\n";
		}
		else
		cout<<"Not a Clique\n";
	}
	return 0;
}



猜你喜欢

转载自blog.csdn.net/baidu_37550206/article/details/79605527