[PAT] Maximal Clique

题目如下

clique is a subset of vertices of an undirected graph such that every two distinct vertices in the clique are adjacent. A maximal clique is a clique that cannot be extended by including one more adjacent vertex. (Quoted from https://en.wikipedia.org/wiki/Clique_(graph_theory))

Now it is your job to judge if a given subset of vertices can form a maximal clique.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers Nv ( 200), the number of vertices in the graph, and Ne, the number of undirected edges. Then Ne lines follow, each gives a pair of vertices of an edge. The vertices are numbered from 1 to Nv.

After the graph, there is another positive integer M ( 100). Then M lines of query follow, each first gives a positive number K ( Nv), then followed by a sequence of K distinct vertices. All the numbers in a line are separated by a space.

Output Specification:

For each of the M queries, print in a line Yes if the given subset of vertices can form a maximal clique; or if it is a clique but not a maximal clique, print Not Maximal; or if it is not a clique at all, print Not a Clique.

Sample Input:

8 10
5 6
7 8
6 4
3 6
4 5
2 3
8 2
2 7
5 3
3 4
6
4 5 4 3 6
3 2 8 7
2 2 3
1 1
3 4 3 6
3 3 2 1

Sample Output:

Yes
Yes
Yes
Yes
Not Maximal
Not a Clique

Clique是一个点集,其中所有顶点两两相连,Maximal Clique就是说这个Clique使得在给定的图中没有更多的点能加入这个Clique形成新的Clique。

不难,用矩阵保存边集,设置两个标志量,标识这个集合是不是Clique、这个Clique是不是Maximal Clique。缓存每一个样例,先检查是不是两两相连,如果是,检查图中剩下的顶点中是否存在顶点v和当前Clique中所有顶点相连。顶点是1-n排列的,省了去一点麻烦。

代码如下

#include <iostream>
#include <vector>
using namespace std;
int e[201][201];
int main() {
	int nv, ne, m, a, b, k;
	scanf("%d %d", &nv, &ne);
	for (int i = 0; i < ne; i++) {
		scanf("%d %d", &a, &b);
		e[a][b] = e[b][a] = 1;
	}
	scanf("%d", &m);
	for (int i = 0; i < m; i++) {
		scanf("%d", &k);
		vector<int> v(k);
		int check[201] = { 0 }, isClique = 1, isMaximal = 1;
		for (int j = 0; j < k; j++) {
			scanf("%d", &v[j]);
			check[v[j]] = 1;
		}//保存样例并记录在check中
		for (int j = 0; j < k; j++) {
			if (isClique == 0) break;
			for (int l = j + 1; l < k; l++) {
				if (e[v[j]][v[l]] == 0) {
					isClique = 0;
					printf("Not a Clique\n");
					break;
				}
			}
		}//判断Clique,不是就continue
		if (isClique == 0) continue;
		for (int j = 1; j <= nv; j++) {
			if (check[j] == 0) {
				for (int l = 0; l < k; l++) {
					if (e[v[l]][j] == 0) break;
					if (l == k - 1) isMaximal = 0;//查到最后还没有break,没有符合条件的点
				}//注意不要习惯性写成一旦==1就把标志变成0,我这样错过。
			}
			if (isMaximal == 0) {
				printf("Not Maximal\n");
				break;
			}
		}
		if (isMaximal == 1) {
			printf("Yes\n");
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/daniel_2046/article/details/80964060
今日推荐