1142 Maximal Clique (25 分)

版权声明:文章都是原创,转载请注明~~~~ https://blog.csdn.net/SourDumplings/article/details/86561697

clique is a subset of vertices of an undirected graph such that every two distinct vertices in the clique are adjacent. A maximal clique is a clique that cannot be extended by including one more adjacent vertex. (Quoted from https://en.wikipedia.org/wiki/Clique_(graph_theory))

Now it is your job to judge if a given subset of vertices can form a maximal clique.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers Nv (≤ 200), the number of vertices in the graph, and Ne, the number of undirected edges. Then Ne lines follow, each gives a pair of vertices of an edge. The vertices are numbered from 1 to Nv.

After the graph, there is another positive integer M (≤ 100). Then M lines of query follow, each first gives a positive number K (≤Nv), then followed by a sequence of K distinct vertices. All the numbers in a line are separated by a space.

Output Specification:

For each of the M queries, print in a line Yes if the given subset of vertices can form a maximal clique; or if it is a clique but not a maximal clique, print Not Maximal; or if it is not a clique at all, print Not a Clique.

Sample Input:

8 10
5 6
7 8
6 4
3 6
4 5
2 3
8 2
2 7
5 3
3 4
6
4 5 4 3 6
3 2 8 7
2 2 3
1 1
3 4 3 6
3 3 2 1

Sample Output:

Yes
Yes
Yes
Yes
Not Maximal
Not a Clique

 C++:

/*
 @Date    : 2018-08-03 22:11:04
 @Author  : 酸饺子 ([email protected])
 @Link    : https://github.com/SourDumplings
 @Version : $Id$
*/

/*
https://pintia.cn/problem-sets/994805342720868352/problems/994805343979159552
 */

#include <iostream>
#include <cstdio>
#include <set>

using namespace std;

const int MAXN = 203;

bool G[MAXN][MAXN];

int main(int argc, char const *argv[])
{
    for (int i = 0; i < MAXN; ++i)
    {
        for (int j = 0; j < MAXN; ++j)
        {
            G[i][j] = false;
        }
    }
    int Nv, Ne;
    scanf("%d %d", &Nv, &Ne);
    for (int i = 0; i < Ne; ++i)
    {
        int v, w;
        scanf("%d %d", &v, &w);
        G[v][w] = G[w][v] = true;
    }

    int W;
    scanf("%d", &W);
    for (int i = 0; i < W; ++i)
    {
        int K;
        scanf("%d", &K);

        set<int> c;
        bool isC = true;
        for (int j = 0; j < K; ++j)
        {
            int m;
            scanf("%d", &m);
            if (j && isC)
            {
                for (auto &cMember : c)
                {
                    if (!G[cMember][m])
                    {
                        isC = false;
                        break;
                    }
                }
            }
            c.insert(m);
        }

        if (isC)
        {
            bool isM = true;
            for (int j = 1; j <= Nv; ++j)
            {
                if (c.find(j) == c.end())
                {
                    bool flag = false;
                    for (auto &cMember : c)
                    {
                        if (!G[cMember][j])
                        {
                            flag = true;
                            break;
                        }
                    }
                    if (!flag)
                    {
                        isM = false;
                        break;
                    }
                }
            }

            if (isM)
            {
                printf("Yes\n");
            }
            else
                printf("Not Maximal\n");
        }
        else
            printf("Not a Clique\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/SourDumplings/article/details/86561697