HDU - Tempter of the Bone(DFS+剪枝)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/lzyws739307453/article/details/86504828

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1010
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Problem Description

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter; 
'S': the start point of the doggie; 
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.

Output

For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.

Sample Input

4 4 5
S.X.
..X.
..XD
....
3 4 5
S.X.
..X.
...D
0 0 0

Sample Output

NO
YES

Problem solving report:

Description: 一个迷宫求S到D的最短时间。
Problem solving: 深搜,只不过要加上奇偶剪枝,要不然该TLE了。

#include <math.h>
#include <stdio.h>
char map[10][10];
int sx, sy, dx, dy;
int n, m, t, temp, vis[10][10];
void dfs(int x, int y, int step) {
    int tx, ty, next[4][2] = {{0, 1}, {1, 0}, {0, -1}, {-1, 0}};
    if ((abs(dx - x) + abs(dy - y)) % 2 != (t - step) % 2 || step > t)
        return ;
    if (map[x][y] == 'D') {
        if (step == t)
            temp = 1;
        return ;
    }
    for (int k = 0; k < 4; k++) {
        tx = x + next[k][0];
        ty = y + next[k][1];
        if (tx < 0 || tx > n - 1 || ty < 0 || ty > m - 1)
            continue;
        if (map[tx][ty] != 'X' && !vis[tx][ty]) {
            vis[tx][ty] = 1;
            dfs(tx, ty, step + 1);
            vis[tx][ty] = 0;
            if (temp)
                return ;
        }
    }
}
int main() {
    int ans;
    while (scanf("%d%d%d", &n, &m, &t), n + m + t) {
        ans = temp = 0;
        for (int i = 0; i < n; i++)
            for (int j = 0; j < m; j++) {
                scanf(" %c", &map[i][j]);
                if (map[i][j] == 'S') {
                    sx = i;
                    sy = j;
                }
                else if (map[i][j] == 'D') {
                    dx = i;
                    dy = j;
                }
                else if (map[i][j] == 'X')
                    ans++;
            }
        if (n * m - ans < t)
        {
            puts("NO");
            continue;
        }
        vis[sx][sy] = 1;
        dfs(sx, sy, 0);
        vis[sx][sy] = 0;
        if (temp)
            puts("YES");
        else puts("NO");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/lzyws739307453/article/details/86504828
今日推荐