HDU-1010-Tempter of the Bone【DFS剪枝】

Tempter of the Bone
Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.
The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

‘X’: a block of wall, which the doggie cannot enter;
‘S’: the start point of the doggie;
‘D’: the Door; or
‘.’: an empty block.

The input is terminated with three 0’s. This test case is not to be processed.

Output
For each test case, print in one line “YES” if the doggie can survive, or “NO” otherwise.

Sample Input
4 4 5
S.X.
..X.
..XD
….
3 4 5
S.X.
..X.
…D
0 0 0

Sample Output
NO
YES

学习:
从S到D,最短路径minPath = abs(iStart - iEnd) + abs(iStart + iEnd)
如果要绕道的话,绕过的道一定为偶数,因为要出去再返回到原道路上。
因此可以用总时间T减去最短路径,那么就可以得到偏离的道路,如果不是偶数直接剪枝。
而且把剪枝放在外面,因为放在DFS里面完全没有意义,想一下走一下你的时间就减少1s。然后你再用剩下的时间去判断有什么意义,不是跟走之前判断一个结果吗。只是徒增你的栈空间。

#include<bits/stdc++.h>
using namespace std;

char Map[10][10];
int vis[10][10];
int n,m,t;
int sx,sy,ex,ey;
int flag;
int dir[4][2]= {{-1,0},{1,0},{0,-1},{0,1}};
void dfs(int x,int y,int cur)
{
    if(flag)return;
    if(x<1||x>n||y<1||y>m||vis[x][y])
        return;
    if(Map[x][y]=='X')
        return;
    int temp=t-cur-abs(ex-x)-abs(ey-y);
    if(temp<0||temp&1)
        return;
    if(cur==t&&x==ex&&y==ey)
    {
        flag=1;
        return;
    }
    vis[x][y]=1;
    for(int i=0;i<4;i++)
    {
        int nex=x+dir[i][0];
        int ney=y+dir[i][1];
        dfs(nex,ney,cur+1);
    }
    vis[x][y]=0;
}


int main()
{
    while(~scanf("%d%d%d",&n,&m,&t)&&(n||m||t))
    {

        for(int i=1; i<=n; i++)
        {
            scanf("%s",Map[i]+1);//从地址map[i][1]开始接收字符串  
        }
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=m; j++)
            {
                if(Map[i][j]=='S')
                {
                    sx=i;
                    sy=j;
                }
                if(Map[i][j]=='D')
                {
                    ex=i;
                    ey=j;
                }
            }
        }
        memset(vis,0,sizeof(vis));
        flag=0;
        dfs(sx,sy,0);
        if(flag)
            printf("YES\n");
        else
            printf("NO\n");
    }
}

猜你喜欢

转载自blog.csdn.net/li_hongcheng/article/details/79401955