hdu 1010 Tempter of the Bone(dfs)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/Void_worker/article/details/82563738

题目:
Tempter of the Bone

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 149127 Accepted Submission(s): 39785

Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

‘X’: a block of wall, which the doggie cannot enter;
‘S’: the start point of the doggie;
‘D’: the Door; or
‘.’: an empty block.

The input is terminated with three 0’s. This test case is not to be processed.

Output
For each test case, print in one line “YES” if the doggie can survive, or “NO” otherwise.

Sample Input
4 4 5
S.X.
..X.
..XD
….
3 4 5
S.X.
..X.
…D
0 0 0

Sample Output
NO
YES

链接:
http://acm.hdu.edu.cn/showproblem.php?pid=1010

代码:

#include <fstream>
#include <iostream>
#include <string>
#include <cmath>
using namespace std;
const int maxn = 10;
char G[maxn][maxn];
bool vis[maxn][maxn];
int dir[4][2] = {{0, 1}, {0, -1}, {1, 0}, {-1, 0}};
int n, m, t, x;
int sx, sy, ex, ey;
bool flag = false;

void dfs(int r, int c, int deep){
    int tem;
    vis[r][c] = true;
    if(deep > t) return ;
    if(r == ex && c == ey && deep == t){
        flag = true;
        return ;
    }
    tem = t - deep - abs(ex - r) - abs(ey - c);
    if(tem < 0 || tem % 2 == 1) return ;
    for(int i = 0; i < 4; ++i){
        int xx = r + dir[i][0];
        int yy = c + dir[i][1];
        if(xx < 1 || yy < 1 || xx > n || yy > m) continue;
        if(!vis[xx][yy] && G[xx][yy] != 'X'){
//            dfs(xx, yy, ++deep);
            dfs(xx, yy, deep + 1);
            if(flag) return ;
            vis[xx][yy] = false;
        }
    }
}

int main(){
//    freopen("a.txt", "r", stdin);
    while (scanf("%d%d%d", &n, &m, &t) != EOF && !(n == 0 && m == 0 && t == 0)){
        getchar();
        x = 0;
        for(int i = 1; i <= n; ++i){
            for(int j = 1; j <= m; ++j){
                scanf("%c", &G[i][j]);
                if(G[i][j] == 'S'){
                    sx = i; sy = j;
                }
                if(G[i][j] == 'D'){
                    ex = i; ey = j;
                }
                if(G[i][j] == 'X') x++;
            }
            getchar();
        }
        if(n * m - x - 1 < t){
            printf("NO\n");
            continue;
        }
        flag = false;
        memset(vis, 0, sizeof(vis));
        dfs(sx, sy, 0);
        if(flag) printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}

写的代码一直运行超时….
剪枝:
https://www.cnblogs.com/wenzhixin/p/7268017.html

猜你喜欢

转载自blog.csdn.net/Void_worker/article/details/82563738