深搜_1013 Battle Over Cities (25 分)

1013 Battle Over Cities (25 分)

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city​1​​-city​2​​ and city​1​​-city​3​​. Then if city​1​​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city​2​​-city​3​​.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

题中要求为如果删除某个节点,与这个节点连接的所有道路全部不通,要求计算出最少需要增加多少条路使图变连通

连通的话,即只含有一个连通分量,减少一个节点,那么不次此节点算在内,之后计算出连通分量的个数num,num-1即为最少添加道路的条数

因为为无向连通图,相对于有向连通图简单了很多

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
#include <queue>
#include <cmath>
#include <set>
#include <map>
#define INF 0x3f3f3f3f
#define ll long long
using namespace std;
const int maxn = 1100;
int n,m,k;
bool mapp[maxn][maxn],used[maxn];

void dfs(int pos)
{
    for(int i = 1;i <= n;i ++)
        if(!used[i] && mapp[pos][i])
        {
            used[i] = 1;
            dfs(i);
        }
}
int main()
{
    int x,y,z,_num = 0;
    scanf("%d%d%d",&n,&m,&k);
    for(int i = 0;i < m;i ++)
    {
        scanf("%d%d",&x,&y);
        mapp[x][y] = 1,mapp[y][x] = 1;
    }
    for(int i = 0;i < k;i ++)
    {
        _num = 0;
        scanf("%d",&z);
        memset(used,0,sizeof(used));
        used[z] = true;
        for(int j = 1;j <= n;j ++)
            if(!used[j])
                used[j] = 1,dfs(j),_num++;
        printf("%d\n",max(0,_num));
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/li1615882553/article/details/84645736
今日推荐