7-3 Pop Sequence(25 分) PAT

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_36032963/article/details/82054396

7-3 Pop Sequence(25 分)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

 思路:

一个数N,pop之前,1~N都要被push到堆栈里,这时需要判断堆栈是否溢出,以及之后的输出顺序是否正确。

PS:提供一组测试数据,一开始没有考虑到这种情况,没有加flag判断,所以过不了:(

    4 6 1

    3 1 2 6 5 4

#include<stdlib.h>
#include<stdio.h>
#define MaxSize 1003
typedef int Data[MaxSize];
typedef struct SNode* PtrtoSNode;
typedef PtrtoSNode Stack;
struct SNode {
	int top;
	int size;
	Data seq;
};
int Push(Stack S,int a) {
	if(S->top<S->size) {
		S->seq[S->top++]=a;
		return 1;
	}
	else return 0;
}
int pop(Stack S) {
	if(S->top)
		return S->seq[--S->top];
	else return 0;
}
int main() {
	int M,N,K,i,j,temp,now,flag;
	Stack S=(Stack)malloc( sizeof(struct SNode) );
	scanf("%d %d %d",&M,&N,&K);
	S->size=M;
	//freopen("d:\\result.txt","w",stdout);
	for(i=0;i<K;i++) {
		S->top=0;
		now=1;
		flag=1;
		for(j=0;j<N;j++) {
			scanf("%d",&temp);
			while(flag && now<=temp) {   //一开始没有加上flag判断,两个测试点过不去
				flag=Push(S,now);
				now++;
			}
			if(pop(S)!=temp) flag=0;
			
		}
		if(!flag) printf("NO\n");
		else printf("YES\n");
	}
	//system("pause");
	return 0;

}

猜你喜欢

转载自blog.csdn.net/qq_36032963/article/details/82054396