PTA Pop Sequence (25分)

释放无限光明的是人心,制造无边黑暗的也是人心,光明和黑暗交织着,厮杀着,这就是我们为之眷恋又万般无奈的人世间。

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO
#include<bits/stdc++.h>
using namespace std;
int m,n,k;
int main(){
    cin>>m>>n>>k;
    for(int i=0;i<k;i++){
        vector<int> v(n);
        bool fg=true;
        for(int j=0;j<n;j++)
            cin>>v[j];
        stack<int> s;
        int ls=0;
        for(int j=1;j<=n;j++){
            s.push(j);
            if(s.size()>m){
                fg=false;
                break;
            }
            while(!s.empty()&&s.top()==v[ls]){
                s.pop();
                ls++;
            }
        }
        if(!s.empty())
            fg=false;
        printf("%s\n",fg?"YES":"NO" );
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_44170305/article/details/108558542