PAT A1162 7-3 Summit (25分)

A summit (峰会) is a meeting of heads of state or government. Arranging the rest areas for the summit is not a simple job. The ideal arrangement of one area is to invite those heads so that everyone is a direct friend of everyone.

Now given a set of tentative arrangements, your job is to tell the organizers whether or not each area is all set.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 200), the number of heads in the summit, and M, the number of friendship relations. Then M lines follow, each gives a pair of indices of the heads who are friends to each other. The heads are indexed from 1 to N.

Then there is another positive integer K (≤ 100), and K lines of tentative arrangement of rest areas follow, each first gives a positive number L (≤ N), then followed by a sequence of L distinct indices of the heads. All the numbers in a line are separated by a space.

Output Specification:

For each of the K areas, print in a line your advice in the following format:

if in this area everyone is a direct friend of everyone, and no friend is missing (that is, no one else is a direct friend of everyone in this area), print Area X is OK..

if in this area everyone is a direct friend of everyone, yet there are some other heads who may also be invited without breaking the ideal arrangement, print Area X may invite more people, such as H. where H is the smallest index of the head who may be invited.

if in this area the arrangement is not an ideal one, then print Area X needs help. so the host can provide some special service to help the heads get to know each other.

Here X is the index of an area, starting from 1 to K.

Sample Input:

8 10
5 6
7 8
6 4
3 6
4 5
2 3
8 2
2 7
5 3
3 4
6
4 5 4 3 6
3 2 8 7
2 2 3
1 1
2 4 6
3 3 2 1

Sample Output:

Area 1 is OK.
Area 2 is OK.
Area 3 is OK.
Area 4 is OK.
Area 5 may invite more people, such as 3.
Area 6 needs help.
  • 思路:
    同PAT A1142 Maximal Clique

  • code:

#include <bits/stdc++.h>
using namespace std;
const int maxn = 100010;
struct Node
{
    int data, nex;
}node[maxn];

void Print(const deque<int> & ans)
{
    if(ans.size() == 0)
    {
        printf("0 -1");
    }else
    {
        for(int i = 0; i < ans.size(); ++i)
        {
            if(i < ans.size() - 1) printf("%05d %d %05d\n", ans[i], node[ans[i]].data, ans[i+1]);
            else printf("%05d %d -1\n", ans[i], node[ans[i]].data);
        }
    }
}

int main()
{
    int first, n, k;
    scanf("%d %d %d", &first, &n, &k);
    for(int i = 0; i < n; ++i)
    {
        int ad;
        scanf("%d", &ad);
        scanf("%d %d", &node[ad].data, &node[ad].nex);
    }
    int head = first;
    vector<int> tmp;
    deque<int> ans;
    while(head != -1)
    {
        tmp.push_back(head);
        head = node[head].nex;
    }
    int i = k - 1;
    while(i < tmp.size())
    {
        for(int j = i; j > i - k; --j)
        {
            ans.push_front(tmp[j]);
        }
        if(i == tmp.size()) break;
        i = i + k < tmp.size() ? i + k : tmp.size() - 1;
    }
    Print(ans);
    return 0;
}
发布了316 篇原创文章 · 获赞 5 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/qq_42347617/article/details/105472258