PAT Advanced1038 Recover the Smallest Number(字符串处理,自定义排序)

版权声明:个人学习笔记记录 https://blog.csdn.net/Ratina/article/details/85545793

链接:PAT Advanced1038

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (≤104​​​ ) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287



题目大意: 给定N个数字(不超过8位),将其拼接起来使得最后的得到的数最小,并将其输出。(不输出前导零)


思路: 一开始想着按字典序排,然后发现并不行。这个拼接顺序应该是遵循:
如果S1+S2 < S2+S1,那么把S1放在S2前面,反之把S2放在S1前面。
这样就很好用string、sort()和自定义cmp()来实现。


以下代码:

#include<bits/stdc++.h>
using namespace std;
bool cmp(string a,string b)
{
	return a+b<b+a;
}
int main()
{  
	string s[10010];
	string t;
	int n,i,j;
	cin>>n;
	for(i=0;i<n;i++)
		cin>>s[i];
	sort(s,s+n,cmp);
	//除以下输出方法外,还可以先拼接好再输出,这样去前导零更方便。
	bool start=false;
	for(i=0;i<n;i++)
	{
		if(i==0)
		{
			t=s[0];
			for(j=0;j<t.length();j++)
			{
					if(t[j]!='0')
						start=true;
					if(start)
						putchar(t[j]);
			}
		}
		else if(start)
			cout<<s[i];
	}
	if(!start)
		cout<<0;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Ratina/article/details/85545793