PAT-1038 Recover the Smallest Number

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/eric4784510/article/details/82079261

1038 Recover the Smallest Number(30 分)

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (≤10​4​​) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287

    有意思的题目,想明白了其实很简单。给一些非负整数,要求返回通过交换顺序所能组成的最小整数。刚开始想复杂了,觉得直接比较字符串大小会因为长度不一致影响判断准确性,当一个字符串是另一个字符串前缀时的确如此,于是我就判断了是否是前缀,是前缀就拼接在一起比较大小,可以通过。看别人都是直接拼接后return s1+s2<s2+s1;没有判断前缀,我发现还是牛人多,不过判断一下前缀执行会快一些。

#include<stdio.h>
#include<vector>
#include<string>
#include<algorithm>
using namespace std;

vector<string> l;
bool isZero(string s){//是否全零
	for(int i=0;i<s.size();i++){
		if(s[i]!='0')
			return false;
	}
	return true;
}
bool cmp(string &s1,string &s2){
	if((s1.length()<s2.length()&&s2.find(s1)==0)||
		(s2.length()<s1.length()&&s1.find(s2)==0))//是前缀
		return s1+s2<s2+s1;//小的在前面
	else
		return s1<s2;
}
int main(){
	int n;
	scanf("%d",&n);

	char tmp[15];
	for(int i=0;i<n;i++){
		scanf("%s",tmp);
		if(isZero(tmp))//全零放开头,不考虑
			continue;
		l.push_back(string(tmp));
	}
	sort(l.begin(),l.end(),cmp);//字符串排序

	if(l.size()>0){
		int k=0;
		for(;k<l[0].size()&&l[0][k]=='0';k++)//去首位零
			;
		l[0]=l[0].substr(k);
	}
	if(l.size()==0)//特判全0
		l.push_back("0");

	for(int i=0;i<l.size();i++){
		printf("%s",l[i].c_str());
	}

	return 0;
}

猜你喜欢

转载自blog.csdn.net/eric4784510/article/details/82079261