【笨方法学PAT】1038 Recover the Smallest Number (30 分)

版权声明:欢迎转载,请注明来源 https://blog.csdn.net/linghugoolge/article/details/84891587

一、题目

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (≤10​4​​) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287

二、题目大意

一串数字,组成最小的数。

三、考点

贪心算法

四、注意

1、如果不知道这个神奇的cmp,解决起来估计特别麻烦吧。

五、代码

#include<iostream>
#include<string>
#include<vector>
#include<algorithm>
using namespace std;

bool cmp(string s1, string s2) {
	return s1 + s2 < s2 + s1;
}

int main() {
	//read
	int n;
	cin >> n;
	vector<string> v(n);
	for (int i = 0; i < n; ++i)
		cin >> v[i];

	//sort
	sort(v.begin(), v.end(), cmp);

	//output
	string s;
	for (int i = 0; i < n; ++i)
		s+=v[i];
	int i = 0;
	while (s[i] == '0' && i < s.length())
		++i;
	if (i == s.length())
		cout << 0 << endl;
	else {
		for (; i < s.length(); ++i)
			cout << s[i];
		cout << endl;
	}

	system("pause");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/linghugoolge/article/details/84891587