PAT (Advanced Level) Practice A1038 Recover the Smallest Number (30 分)(C++)(甲级)(string)

版权声明:假装有个原创声明……虽然少许博文不属于完全原创,但也是自己辛辛苦苦总结的,转载请注明出处,感谢! https://blog.csdn.net/m0_37454852/article/details/86513117

1038 Recover the Smallest Number (30 分)
Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (≤10​4 ) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:

5 32 321 3214 0229 87
Sample Output:

22932132143287


using namespace std;
#include<algorithm>
#include<iostream>
#include<cstdio>
#include<cstring>

bool cmp(string A, string B)
{
    return A+B < B+A;//string类型,+表示拼接
}

string S, T[10010];

int main()
{
    int N, i, flag = 0;
    cin >> N;
    for(i=0; i<N; i++) cin >> T[i];
    sort(T, T+N, cmp);
    for(i=0; i<N; i++) S += T[i];//全部拼接到S
    int len = S.length();
    for(i=0; i<len; i++)
    {
        if(!flag && S[i] == '0') continue;//前面的0不输出
        flag = 1;
        printf("%c", S[i]);
    }
    if(!flag) printf("0");//若全为0则直接输出0
    return 0;
}

猜你喜欢

转载自blog.csdn.net/m0_37454852/article/details/86513117