PAT:A1038 Recover the Smallest Number

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/Ecloss/article/details/81938991

PAT:A1038 Recover the Smallest Number 

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given {32, 321, 3214, 0229, 87}, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (<=10000) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Do not output leading zeros.

Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287

代码:

#include<cstdio>
#include<string>
#include<iostream> 
#include<algorithm>

using namespace std;

const int maxn = 10010;
string str[maxn];

bool cmp(string a, string b) {
	return a + b < b + a;	// 如果a+b < b+a 那么a排在前面 
}

int main() {
	int N;
	cin >> N;
	for(int i = 0; i < N; i++) {
		cin >> str[i];
	}
	sort(str, str+N, cmp);
	string ans;
	for(int i = 0; i < N; i++) {
		ans += str[i];
	}
	while(ans.size() > 0 && ans[0] == '0') {
		ans.erase(ans.begin());
	}
	if(ans.size() == 0) cout << 0;
	else cout << ans;
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/Ecloss/article/details/81938991